POJ2488 A Knight's Journey[dfs]



D - A Knight's Journey
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4


题意:

给定 n,m 看马能不能走遍整个棋盘 按字典序输出


简单的dfs 注意了next的写法  因为要按字典序输出

其实找到应该就可以直接返回了,没直接返回 感觉更耗时  

之后写的时候注意一下就好.



#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<map>
using namespace std;
const int N=30;
bool mark[N][N],flag;
int next[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
int road[N*N][2];
int p,q;
void dfs(int x,int y,int step)
{
    road[step][0]=x;
    road[step][1]=y;
    if (step==p*q)
    {
        flag=true;
        return ;
    }
    for (int i=0;i<8;i++)
    {
        int nx=x+next[i][0];
        int ny=y+next[i][1];
        if (nx>0 && nx<=p && ny>0 && ny<=q && !mark[nx][ny] && !flag)//记得回溯
        {
            mark[nx][ny]=1;
            dfs(nx,ny,step+1);
            mark[nx][ny]=0;
        }
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    for (int test=1;test<=T;test++)
    {
        memset(mark,0,sizeof(mark));
        scanf("%d%d",&p,&q);
        flag=0;
        mark[1][1]=1;
        dfs(1,1,1);
        printf("Scenario #%d:\n",test);
        if (flag)
            for (int i=1;i<=p*q;i++)
                printf("%c%d",road[i][1]+'A'-1,road[i][0]);//貌似题目那里是x y反过来? 之前一直以为自己错了, 但是反过来跟样例一样
        else
            printf("impossible");
        printf("\n\n");
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值