POJ2481 Cows[树状数组+离散化]


C - Cows
Time Limit:3000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good. 

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E]. 

But some cows are strong and some are weak. Given two cows: cow  i and cow  j, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cow  i is stronger than cow  j

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases. 
For each test case, the first line is an integer N (1 <= N <= 10  5), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 10  5) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge. 

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cow  i

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0

Hint

Huge input and output,scanf and printf is recommended.

题意:

给你n只牛 找到比它自己强的牛的个数


把题目给的s 和 e抽象成坐标         

找到比自己的y要大 但是比x要小的点的个数

跟POJ2352 差不多 但是不一样的是 这个是要找左上角的点的个数

但是输入的时候 并没有排序  要先自己排序.  用上离散化可以.. 

感觉自己做的第一次排序没有用 不过算了 都写了

记得 如果有相同的点 ans就和上一个是一样的 

如果不相同 就算一次

画个图.. (随便拿截屏然后再画的 别嫌丑)





#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<vector>
using namespace std;
const int N=1e5+10;
int reflect[N],bit[N],ans[N];
int n;
struct node
{
    int s,e,id;
}num[N];
bool cmp1(const node &a,const node &b)
{
    return a.s<b.s;
}
bool cmp2(const node &a,const node &b)
{
    if (a.e==b.e)
        return a.s<b.s;
    return a.e>b.e;
}
int lowbit(int x)
{
    return x&(-x);
}
void update(int x,int val)
{
    while (x<=n)
    {
        bit[x]+=val;
        x+=lowbit(x);
    }
}
int query(int x)
{
    int sum=0;
    while (x>0)
    {
        sum+=bit[x];
        x-=lowbit(x);
    }
    return sum;
}
int main()
{
    while (~scanf("%d",&n) && n)
    {
        memset(bit,0,sizeof(bit));
        memset(ans,0,sizeof(ans));
        for (int i=1 ; i<=n ; i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            num[i].s=x+1;
            num[i].e=y+1;
            num[i].id=i;
        }
        sort(num+1,num+n+1,cmp1);
        for (int i=1 ; i<=n ; i++)//离散化
                reflect[num[i].s]=i;
        sort(num+1,num+n+1,cmp2);
        update(reflect[num[1].s],1);
        for (int i=2 ; i<=n ; i++)
        {
            if (num[i-1].s==num[i].s && num[i-1].e==num[i].e)
                ans[num[i].id]=ans[num[i-1].id];
            else
                ans[num[i].id]=query(reflect[num[i].s]);
            update(reflect[num[i].s],1);
        }
        for (int i=0 ; i<n ; i++)
        {
            if (i)
                printf(" ");
            printf("%d",ans[i+1]);
        }
        printf("\n");
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值