uva305 - Joseph 约瑟夫问题变形

 Joseph 

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from amongn people, numbered 1, 2, ...,n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the firstk are good guys and the lastk bad guys. You have to determine such minimalm that all the bad guys will be executed before the first good guy.

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 <k < 14.

Output

The output file will consist of separate lines containing m corresponding tok in the input file.

Sample Input

3
4
0

Sample Output

5
30

  约瑟夫问题真是高端。。各种各样的。

  最经典的是n个人一圈,编号0到n-1,每k个人踢掉一个,设n个人一圈最后一个被踢掉的人编号f[n],则有f[1]=0,f[n]=(f[n-1]+k)%n。

  这个问题是有2*K个人,前K个是好人,后K个坏人,每m人踢掉一个,让你求最小的m,使最先踢掉的K个人都是坏人。

  经典问题是从前往后推,这个问题是从后往前推。设f[n]是2*k个人一圈第n个被踢出的人的相对编号,注意是相对编号,比如说本来有6个人编号0-5,编号4的被踢了,那么编号5的相对编号变成4,也就是踢掉之后的编号往前移动一个。f[n]=(f[n-1]+m-1)%(2*K-(n-1))。

  由于m%2K>K,把符合这个条件的m从小到大遍历,判断是否符合题意。判断的时候只要前k个被踢的相对编号都>=K就行了。因为就算是相对编号,前K个也是不能被踢的,所以前K个被踢的相对编号都大于等于K。

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<sstream>
#include<cstring>
#include<cmath>
#include<queue>
#include<map>
#include<set>
#define INF 0x3f3f3f3f
#define MAXN 130
#define MAXM 12
#define eps 1e-9
#define pi 4*atan(1.0)
#define pii pair<int,int>
using namespace std;
int K,ans[20];
bool judge(int k,int m){
    int x=0;
    for(int i=0;i<k;i++){
        x=(x+m-1)%(2*k-i);
        if(x<k) return false;
    }
    return true;
}

int main(){
    freopen("in.txt","r",stdin);
    for(int k=1;k<14;k++){
        int flag=0,m;
        for(int i=0;;i++){
            for(int j=k+1;j<=2*k;j++){
                m=i*2*k+j;
                if(judge(k,m)){
                    flag=1;
                    break;
                }
            }
            if(flag){
                ans[k]=m;
                break;
            }
        }
    }
    while(scanf("%d",&K),K){
        printf("%d\n",ans[K]);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值