poj1284 Primitive Roots 原根个数

Description

We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (x i mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive root modulo 7.
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p.

Input

Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator.

Output

For each p, print a single number that gives the number of primitive roots in a single line.

Sample Input

23
31
79

Sample Output

10
8
24

原根的定义

原根Primitive Root。
设m是正整数,a是整数,若a模m的阶等于φ(m),则称a为模m的一个原根。(其中φ(m)表示m的欧拉函数)
假设一个数g对于P来说是原根,那么g^i mod P的结果两两不同,且有 1<g<P, 0<i<P,那么g可以称为是P的一个原根,归根到底就是g^(P-1) = 1 (mod P)当且仅当指数为P-1的时候成立.(这里P是素数).
简单来说,g^i mod p ≠ g^j mod p (p为素数)
其中i≠j且i, j介於1至(p-1)之间
则g为p的原根。
求原根目前的做法只能是从2开始枚举,然后暴力判断g^(P-1) = 1 (mod P)是否当且当指数为P-1的时候成立
而由于原根一般都不大,所以可以暴力得到.

2原根的性质

1)可以证明,如果正整数( a, m) = 1和正整数 d 满足a^d≡1(mod 7),则 d 整除 φ( m)。因此 Ordm( a)整除φ( m)。在例子中,当 a= 3时,我们仅需要验证 3 的 1 、2、3 和 6 次方模 7 的余数即可。
2)记δ = Ordm( a),则a^1,……a^(δ-1)模 m 两两不同余。因此当 a是模 m的原根时,a^0,a^1,……a^(δ-1)构成模 m 的简化剩余系。
3)模 m有原根的充要条件是 m= 1,2,4, p,2 p, p^n,其中 p是奇质数, n是任意正整数。
4)对正整数( a, m) = 1,如果 a 是模 m 的原根,那么 a 是 整数模n乘法群(即加法群 Z/m Z的可逆元,也就是所有与 m  互素的正整数构成的等价类构成的乘法群) Zn的一个生成元。由于 Zn有 φ( m)个元素,而它的生成元的个数就是它的可逆元个数,即 φ(φ( m))个,因此当模 m有原根时,它有φ(φ( m))个原根。

  百度百科上的,现在也不是很懂。根据公式,对于有原根的原根个数为φ(φ(m)),因为这道题P是素数,所以答案为phi(P-1)。

#include<iostream>
#include<queue>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<set>
#include<map>
#include<vector>
#include<algorithm>
#define eps 1e-9
#define MAXN 10000
using namespace std;
int P;
int Euler(int n){
    int i,ret=n;
    for(int i=2;i*i<=n;i++){
        if(n%i==0){
            ret=ret-ret/i;
            while(n%i==0) n/=i;
        }
        if(n==1) break;
    }
    if(n>1) ret=ret-ret/n;
    return ret;
}
int main(){
    while(scanf("%d",&P)!=EOF){
        printf("%d\n",Euler(P-1));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值