hdu2970 Suffix reconstruction 后缀数组反过来构造串

Suffix reconstruction

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 253    Accepted Submission(s): 142


Problem Description
Given a text s[1..n] of length n, we create its suffix array by taking all its suffixes: s[1..n], s[2..n],...., s[n..n] and sorting them lexicographically. As a result we get a sorted list of suffixes: s[p(1)..n], s[p(2)..n],..., s[p(n)..n] and call the sequence p(1),p(2),...,p(n) the suffix array of s[1..n].

For example, if s = abbaabab, the sorted list of all suffixes becomes: aabab, ab, abab, abbaabab, b, baabab, bab, bbaabab and the suffix array is 4, 7, 5, 1, 8, 3,6, 2.


It turns out that it is possible to construct this array in a linear time. Your task will be completely different, though: given p(1), p(2), p(3),... , p(n) you should check if there exist at least one text consisting of lowercase letters of the English alphabet for which this sequence is the suffix array. If so, output any such text. Otherwise output -1.
 

Input
The input contains several descriptions of suffix arrays. The first line contains the number of descriptions t (t <= 100). Each description begins with a line containing the length of both the text and the array n (1 <= n <= 500000). Next line contains integers p(1), p(2), ... ,p(n). You may assume that 1 <= p(i) <= n and no value of p(i) occurs twice. Total size of the input will not exceed 50MB.
 

Output
For each test case
If there are multiple answers, output the smallest dictionary order in the given suffix array. In case there is no such text consisting of lowercase letters of the English alphabet, output -1.
 

Sample Input
  
  
6 2 1 2 2 2 1 3 2 3 1 6 3 4 5 1 2 6 14 3 10 2 12 14 5 13 4 1 8 6 11 7 9 7 5 1 7 4 3 2 6
 

Sample Output
  
  
ab aa bab bcaaad ebadcfgehagbdc bcccadc

           第i个元素表示第i大的后缀的开始下标,相当于sa,构造出满足这个sa的串,如果超过z输出-1。

           想到了从a开始,最小的后缀位置先放上a,再放第二小的位置,能不加就不加。但是不知道怎么搞的,一直认为某个位置的后面的位置可能还没有构造,导致不能确定加不加。。其实只要根据下一个位置的sa就可以判断了。。

           先求出rank(rank[i]是第i个位置开始的后缀排多少),sa从小到大的顺序构造,设上个构造的位置a=sa[i-1],现在构造的位置b=sa[i],那么如果位置a+1的sa大于位置b+1的sa,则要加1(因为后缀b要比后缀a大),否则不加。

#include<iostream>
#include<queue>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<set>
#include<map>
#include<vector>
#include<stack>
#include<algorithm>
using namespace std;
typedef long long LL;
typedef pair<int,int> pii;

const int MAXN=500010;
const int MAXM=2600;
const int INF=0x3f3f3f3f;
const int MOD=2520;

int T,N;
int sa[MAXN],r[MAXN];
char ans[MAXN];

int main(){
    freopen("in.txt","r",stdin);
    scanf("%d",&T);
    while(T--){
        scanf("%d",&N);
        for(int i=1;i<=N;i++){
            scanf("%d",&sa[i]);
            r[sa[i]]=i;
        }
        char c='a';
        r[N+1]=0;
        ans[sa[1]]='a';
        for(int i=2;i<=N;i++){
            int a=sa[i-1],b=sa[i];
            if(r[a+1]>r[b+1]) c++;
            ans[sa[i]]=c;
            if(c>'z') break;
        }
        if(c>'z') printf("-1\n");
        else{
            for(int i=1;i<=N;i++) printf("%c",ans[i]);
            puts("");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值