字符->hdu 2970 Suffix reconstruction

Suffix reconstruction
Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given a text s[1..n] of length n, we create its suffix array by taking all its suffixes: s[1..n], s[2..n],...., s[n..n] and sorting them lexicographically. As a result we get a sorted list of suffixes: s[p(1)..n], s[p(2)..n],..., s[p(n)..n] and call the sequence p(1),p(2),...,p(n) the suffix array of s[1..n]. 

For example, if s = abbaabab, the sorted list of all suffixes becomes: aabab, ab, abab, abbaabab, b, baabab, bab, bbaabab and the suffix array is 4, 7, 5, 1, 8, 3,6, 2.


It turns out that it is possible to construct this array in a linear time. Your task will be completely different, though: given p(1), p(2), p(3),... , p(n) you should check if there exist at least one text consisting of lowercase letters of the English alphabet for which this sequence is the suffix array. If so, output any such text. Otherwise output -1.
 

Input

The input contains several descriptions of suffix arrays. The first line contains the number of descriptions t (t <= 100). Each description begins with a line containing the length of both the text and the array n (1 <= n <= 500000). Next line contains integers p(1), p(2), ... ,p(n). You may assume that 1 <= p(i) <= n and no value of p(i) occurs twice. Total size of the input will not exceed 50MB.
 

Output

For each test case 
If there are multiple answers, output the smallest dictionary order in the given suffix array. In case there is no such text consisting of lowercase letters of the English alphabet, output -1.
 

Sample Input

     
     
6 2 1 2 2 2 1 3 2 3 1 6 3 4 5 1 2 6 14 3 10 2 12 14 5 13 4 1 8 6 11 7 9 7 5 1 7 4 3 2 6
 

Sample Output

     
     
ab aa bab bcaaad ebadcfgehagbdc bcccadc
 

#include <iostream>

using namespace std;

#define MAXN 500000 + 10

int n;
int cmp[MAXN];
char ans[MAXN];

struct Node
{
	int val, id;
}temp[MAXN];

void input()
{
	int t;
	
	cin >> t;
	
	while (t--)
	{
		cin >> n;
		
		for (int i = 0; i < n; i++)
		{
			cin >> temp[i].val;
			temp[i].id = i; 
			cmp[temp[i].val] = i;
		}
		
		ans[temp[0].val] = 'a';
		
		int per = temp[0].val;
		
		bool flag = false;
		
		for (int i = 1; i < n; i++)
		{
			int next = temp[i].val;
			
			if (cmp[next + 1] < cmp[per + 1])
			{
				ans[next] = ans[per] + 1;	
			}
			else
			{
				ans[next] = ans[per];
			}
			
			if (ans[next] > 'z')
			{
				flag = true;
				break;
			}
			per = next;
		}
		
		if (flag)
		{
			cout << -1 << endl;
		}
		else
		{
			for (int i = 1; i <= n; i++)
			{
				cout << ans[i];
			}
			
			cout << endl;
		}
	}
}

int main()
{
	std::ios::sync_with_stdio(false);
	input();
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值