poj2486 Apple Tree 树形DP

Apple Tree
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8670 Accepted: 2882

Description

Wshxzt is a lovely girl. She likes apple very much. One day HX takes her to an apple tree. There are N nodes in the tree. Each node has an amount of apples. Wshxzt starts her happy trip at one node. She can eat up all the apples in the nodes she reaches. HX is a kind guy. He knows that eating too many can make the lovely girl become fat. So he doesn’t allow Wshxzt to go more than K steps in the tree. It costs one step when she goes from one node to another adjacent node. Wshxzt likes apple very much. So she wants to eat as many as she can. Can you tell how many apples she can eat in at most K steps.

Input

There are several test cases in the input
Each test case contains three parts.
The first part is two numbers N K, whose meanings we have talked about just now. We denote the nodes by 1 2 ... N. Since it is a tree, each node can reach any other in only one route. (1<=N<=100, 0<=K<=200)
The second part contains N integers (All integers are nonnegative and not bigger than 1000). The ith number is the amount of apples in Node i.
The third part contains N-1 line. There are two numbers A,B in each line, meaning that Node A and Node B are adjacent.
Input will be ended by the end of file.

Note: Wshxzt starts at Node 1.

Output

For each test case, output the maximal numbers of apples Wshxzt can eat at a line.

Sample Input

2 1 
0 11
1 2
3 2
0 1 2
1 2
1 3

Sample Output

11
2

  一棵树,每个结点上有有一些苹果,从1开始最多只能走K步,能吃到多少苹果。

  dp[i][j][0]表示从结点i往下走不超过j步并且回到结点i的最大值,dp[i][j][1]表示从结点i往下走不超过j步并且但不一定回到结点i的最大值,进行状态转移时注意dp[i][j][1]有两种情况,从左边走回来再往右走和从右边走回来再往左走。

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
typedef long long LL;

const LL MAXN=110;
const LL MAXM=15;
const LL INF=0x3f3f3f3f;

int N,K;
int dp[MAXN][2*MAXN][2],a[MAXN];
vector<int> g[MAXN];

void dfs(int u,int fa){
    int len=g[u].size();
    if(len<=1&&g[u][0]==fa) return;
    for(int i=0;i<len;i++){
        int v=g[u][i];
        if(v!=fa){
            dfs(v,u);
            for(int j=K;j>0;j--){
                for(int k=0;k<=j-2;k++) dp[u][j][0]=max(dp[u][j][0],dp[v][k][0]+dp[u][j-k-2][0]);
                for(int k=0;k<=j-2;k++) dp[u][j][1]=max(dp[u][j][1],dp[v][k][0]+dp[u][j-k-2][1]);
                for(int k=0;k<j;k++) dp[u][j][1]=max(dp[u][j][1],dp[v][k][1]+dp[u][j-k-1][0]);
            }
        }
    }
}

int main(){
    freopen("in.txt", "r", stdin);
    while(scanf("%d%d",&N,&K)!=EOF){
        for(int i=1;i<=N;i++) scanf("%d",&a[i]);
        for(int i=1;i<=N;i++) g[i].clear();
        int u,v;
        for(int i=0;i<N-1;i++){
            scanf("%d%d",&u,&v);
            g[u].push_back(v);
            g[v].push_back(u);
        }
        if(N==1){
            printf("%d\n",a[1]);
            continue;
        }
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=N;i++) dp[i][0][0]=dp[i][0][1]=a[i];
        dfs(1,-1);
        printf("%d\n",dp[1][K][1]);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值