POJ3411 DFS最小计算消费值

Description

A network of m roads connects N cities (numbered from 1 to N). There may be more than one road connecting one city with another. Some of the roads are paid. There are two ways to pay for travel on a paid road i from city ai to city bi:

  • in advance, in a city ci (which may or may not be the same as ai);
  • after the travel, in the city bi.

The payment is Pi in the first case and Ri in the second case.

Write a program to find a minimal-cost route from the city 1 to the city N.

Input

The first line of the input contains the values of N and m. Each of the following m lines describes one road by specifying the values of aibiciPiRi (1 ≤ ≤ m). Adjacent values on the same line are separated by one or more spaces. All values are integers, 1 ≤ m, N ≤ 10, 0 ≤ Pi , Ri ≤ 100, Pi ≤ Ri (1 ≤ ≤ m).

Output

The first and only line of the file must contain the minimal possible cost of a trip from the city 1 to the city N. If the trip is not possible for any reason, the line must contain the word ‘impossible’.

Sample Input

4 5
1 2 1 10 10
2 3 1 30 50
3 4 3 80 80
2 1 2 10 10
1 3 2 10 50

Sample Output

110

</pre><pre name="code" class="cpp">#include <IOSTREAM>
#include <CSTDLIB>
using namespace std;




#define MAX 11
#define MAXCOUNT 2000




typedef struct
{
	int ai, bi, ci, Pi, Ri;
}CITY;




CITY city[MAX];
int visit[MAX];
int N, m;
int min_cost;




void search_dfs(int in_city, int cost_count)
{
	if (in_city == N&&min_cost > cost_count)
	{
		min_cost = cost_count;
		return;
	}
	int ic;
	for (ic = 1; ic <= m; ic++)             //
	{
		if (in_city == city[ic].ai&&visit[city[ic].bi] <= 3)
		{
			visit[city[ic].bi]++;
			if (visit[city[ic].ci] > 0) //如果曾经到过城市C则用Pi的花费计算,否则用Ri的花费计算
				search_dfs(city[ic].bi, cost_count + city[ic].Pi);
			else
				search_dfs(city[ic].bi, cost_count + city[ic].Ri);
			visit[city[ic].bi]--;
		}
	}
	return;
}




int main()
{
	while (cin >> N >> m)
	{
		if ((!(N >= 1 && N <= 10)) || (!(m >= 1 && m <= 10)))
			continue;
		memset(city, 0, sizeof(city));
		memset(visit, 0, sizeof(visit));
		min_cost = MAXCOUNT;
		int ic;
		for (ic = 1; ic <= m; ic++)
		{
			cin >> city[ic].ai >> city[ic].bi >> city[ic].ci >> city[ic].Pi >> city[ic].R;
		}
		visit[city[ic].ai] = 1;
		search_dfs(1, 0);
		if (min_cost >= MAXCOUNT)
			cout << "impossible" << endl;
		else
			cout << min_cost << endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值