zoj 1526||poj 1423 big number (大数 stirling公式)

In many applications very large integers numbers arerequired. Some of these applications are using keys for secure transmission ofdata, encryption, etc. In this problem you are given a number, you have todetermine the number of digits in the factorial of the number.


Input

Input consists of several lines of integer numbers. The first line contains aninteger n, which is the number of cases to be tested, followed by n lines, oneinteger 1 <= n <= 10^7 on each line.


Output

The output contains the number of digits in the factorial of the integersappearing in the input.


Sample Input

2
10
20


Sample Output

7
19

题意:

给定一个数n,求其n!的长度。

分析

 

普通的话tooooooooooooold

所以可能会认为是大数问题, 实际上也算吧,但一般大数处理会超空间。

实际上此题还有另外做法,公式,那样的话,这也就一水题了,但第一次接触log函数求数长度和斯特林公式,所以纪念意义还是很大的。

斯特林公式: 

在n很大的情况下,斯特林公式会更显得准确,具体推导可见百度百科。

求M长度公式:对于数M的位数等于将其取整后+1

Len=(int)log10(M)+1

 

 

还有库函数log


#include <iostream>
#include <math.h>
 
using namespace std;
 
const double e= 2.718281828459 ;
const double pi= 3.1415926535898 ;
 
int main()
{
     longlong n,tt;
     cin>>tt;
     while(tt>0)
     {
         tt--;
         cin>>n;
         longlong ans = (longlong)((double)log10(sqrt(2* pi * n)) + n * log10(n / e))+1;
         cout<<ans<<endl;
     }
     return0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值