HDOJ1013 Digital Roots(高精度+数位分离求和)

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 80317    Accepted Submission(s): 25127


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
  
  
24 39 0
 

Sample Output
  
  
6 3
 

Source

【分析】数根问题:计算正整数n的各位数字之和(记为sum)。

        (1)若n是个位数,则n的数根是其本身;

        (2)若求得的sum是个位数,则n的数根为sum;

        (3)否则对sum求各位数字之和,直到结果为个位数为止。

        这里需要注意n是大整数,因此用字符数组(字符串)保存之。

#include <stdio.h>
#include <string.h>
char num[1010];
int main()
{
	int i,n;
	int sum,temp;
    while(scanf("%s",num)!=EOF)
    {
    	sum=0;
    	if(strcmp(num,"0")==0)
    		break;
    	for(i=0;i<strlen(num);i++)
    		sum+=(num[i]-'0');
    	n=sum;
		while(n>=10)
    	{
    		temp=n;
    		sum=0;
    		while(temp!=0)
    		{
    			sum+=(temp%10);
    			temp/=10;
			}
			n=sum;
		}
		printf("%d\n",n);
	}
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值