1005. Spell It Right (20)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.
Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).
Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:12345Sample Output:
one five
【分析】数位基本操作(逐位求和+分离)
对输入的数逐位求和,然后将结果进行数位分离,对应输出每个数位的英文单词即可。
需要注意:由于N<=10^100,输入数字要用字符串保存。
#include <stdio.h>
#include <string.h>
#define maxlen 105
char num[maxlen];
int digit[5];
char num_to_English[][10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
int main()
{
int i;
int len=0,sum=0;
scanf("%s",num);
for(i=0;i<strlen(num);i++)
sum+=(num[i]-'0');
if(sum==0)
printf("zero\n");
else
{
while(sum!=0)
{
digit[len++]=sum%10;
sum/=10;
}
for(i=len-1;i>0;i--)
printf("%s ",num_to_English[digit[i]]);
printf("%s\n",num_to_English[digit[0]]);
}
return 0;
}