HDOJ1200. To and Fro(字符串处理+字符矩阵)

To and Fro

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7251    Accepted Submission(s): 4998


Problem Description
Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down

t o i o y
h p k n n
e l e a i
r a h s g
e c o n h
s e m o t
n l e w x


Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

toioynnkpheleaigshareconhtomesnlewx

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.
 

Input
There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.
 

Output
Each input set should generate one line of output, giving the original plaintext message, with no spaces.
 

Sample Input
5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0
 

Sample Output
theresnoplacelikehomeonasnowynightx
thisistheeasyoneab

【分析】字符串处理+字符矩阵

        题意:多组输入,每组输入矩阵列数col 及一行长度不超过200的 由小写字母组成的文本,将其填入col列矩阵中。填充时按行进行,填充顺序右-左交替。最后按列序打印字符矩阵以获得明文。

#include <stdio.h>
#include <string.h>
int ln,col;
char str[210];
char mat[105][25];
//填充ln行 col列字符矩阵
void fillMat(char *s,char mt[][25],int ln,int col)
{
	int i=0,j=0;
	//cur-当前待填入字符的下标 dir-填充方向(-1左 1右) 
	int cur=0,dir=1;   
	int len=strlen(s);
	while(cur<len)
	{
		//向右填充第i行 
		if(dir==1)
		{
			for(j=0;j<col;j++)
				mt[i][j]=s[cur++];
		}
		//向左填充第i行 
		else
		{
			for(j=col-1;j>=0;j--)
				mt[i][j]=s[cur++];
		}
		//准备填充下一行 
		i++;
		//方向变化 
		dir=-dir;
	}
}
//获取明文 
void getMsg(char mt[][25],int ln,int col)
{
	int i,j;
	for(j=0;j<col;j++)
		for(i=0;i<ln;i++)
			printf("%c",mt[i][j]);
	printf("\n");
}
int main()
{
	int i,len;
	while(scanf("%d",&col)!=EOF)
	{
		if(col==0)
			break;
		scanf("%s",str);
		len=strlen(str);
		//确定填充区域大小-ln行 col列 
		ln=len/col;
		fillMat(str,mat,ln,col);
		getMsg(mat,ln,col);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值