HDOJ 1200 To and Fro(简单模拟)

To and Fro

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5473    Accepted Submission(s): 3785


Problem Description
Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down

t o i o y
h p k n n
e l e a i
r a h s g
e c o n h
s e m o t
n l e w x


Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

toioynnkpheleaigshareconhtomesnlewx

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.
 

Input
There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.
 

Output
Each input set should generate one line of output, giving the original plaintext message, with no spaces.
 

Sample Input
  
  
5 toioynnkpheleaigshareconhtomesnlewx 3 ttyohhieneesiaabss 0
 

Sample Output
  
  
theresnoplacelikehomeonasnowynightx thisistheeasyoneab
 

题意:两基友设计图形密码,将一行有序的字符串,按S型排成一个宽为n的矩阵。题目要求现给出该矩阵的字符串,将其还原成原来的有序字符串密码。

(⊙o⊙)…这题意写的真狗屁,看我题解的童鞋还是自己读题吧。


解题思路: 先将输入的字符串还原成字符矩阵,用二维数组模拟即可。再将该二维数组竖向输出即可。

代码如下:

#include<stdio.h>
#include<string.h>
int main()
{
	int i,j,k,n,m,len;
	char str[210],a[210][210];
	while(scanf("%d",&n)&&n!=0)
	{
		scanf("%s",str);
		len=strlen(str);
		m=len/n;  i=0;
		for(j=0;j<m;j++)
		{
			if(j%2==0)
			{
				for(k=0;k<n;k++)
				{
					a[j][k]=str[i];
					i++;
				}
			}
			else
			{
				for(k=n-1;k>=0;k--)
				{
					a[j][k]=str[i];
					i++;
				}
			}
		}
		for(i=0;i<n;i++)
		{
			for(j=0;j<m;j++)
			{
				printf("%c",a[j][i]);
			}
		}
		printf("\n");
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值