HDOJ1009. FatMouse' Trade(贪心-分数背包)

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 87866    Accepted Submission(s): 30519


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
 

Sample Output
13.333
31.500

【分析】贪心——分数背包

        题意:老鼠有猫粮M;N个仓库中,第i个仓库有JavaBeans J[i],进入该仓库拿到J[i] JavaBeans需要猫粮F[i];用F[i]*a% 猫粮 可换取 J[i]*a% JavaBeans。问老鼠如何获得最多的JavaBeans。

        这里的猫粮即"代价",JavaBeans即"价值",于是问题转化为如何付出最小代价获得最大价值。

        因此,我们可考虑使用贪心策略:优先拿 价值/代价 数值大的。此策略的正确性由条件 用F[i]*a% 猫粮 可换取 J[i]*a% JavaBeans 保证。

        该问题即"分数背包"问题。

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=1010;
int M,N;
double maxamount;
struct food
{
	int J;
	int F;
	double JdivF;
} fd[maxn];
bool cmp(struct food fd1,struct food fd2)
{
	return (fd1.JdivF>fd2.JdivF);
}
int main()
{
	int i;
	while(scanf("%d %d",&M,&N)!=EOF)
	{
		if(M==-1 && N==-1)
			break;
		for(i=0;i<N;i++)
		{
			scanf("%d %d",&fd[i].J,&fd[i].F);
			fd[i].JdivF=fd[i].J*1.0/fd[i].F;
		}
		sort(fd,fd+N,cmp);
		maxamount=0;
		for(i=0;i<N;i++)
		{
			if(M-fd[i].F>=0)
			{
				maxamount+=fd[i].J;
				M-=fd[i].F;
			}
			else
			{
				maxamount+=(fd[i].JdivF*M);
				break;
			} 
		}
		printf("%.3lf\n",maxamount);
	}
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值