HDOJ1035. Robot Motion(DFS)

Robot Motion

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12034    Accepted Submission(s): 5702


Problem Description


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.
 

Input
There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.
 

Output
For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.
 

Sample Input
3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 
 

Sample Output
10 step(s) to exit
3 step(s) before a loop of 8 step(s)

【分析】DFS
        题意:标有方向的r*c大小的格子区域内,机器人从地图第1行第c列位置出发,按区域内每个点指引的方向走。问走多少步机器人能离开格子区域,或者走多少步能进入循环圈?
        根据题意,走过的点不再重复走,因此没有“回溯”。故标记已走过的点,并使用一个队列保存其路径即可。
        如果出界,则结束;或者走到了已走过的点,则说明进入循环圈。
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxlen=15;
int r,c,start;
char grid[maxlen][maxlen];
char dir_ch[4]={'N','S','W','E'};
int vis[maxlen][maxlen];
int dir_val[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
struct queue
{
	int x;
	int y;
} q[maxlen*maxlen];
void dfs(int x,int y,int steps)
{
	int i;
	int newx,newy;
	char temp;
	q[steps].x=x;
	q[steps].y=y;
	//出界:离开格子区域 
	if(!(x>=0 && x<r && y>=0 && y<c))
	{
		printf("%d step(s) to exit\n",steps);
		return;
	}
	//进入循环圈 
	else if(vis[x][y]==1)
	{
		//在队列中找循环起点,起点即进入循环圈之前的步数 终点-起点即循环圈长度 
		for(i=0;i<steps;i++)
		{
			if(q[i].x==x && q[i].y==y)
			{
				printf("%d step(s) before a loop of %d step(s)\n",i,steps-i);
				break;
			}
		}
		return;
	}
	else
	{
		vis[x][y]=1;
		for(i=0;i<4;i++)
		{
			if(grid[x][y]==dir_ch[i])
			{
				newx=x+dir_val[i][0];
				newy=y+dir_val[i][1];
				dfs(newx,newy,steps+1);
			}
		}
	}
}
int main()
{
	int i;
	while(scanf("%d %d",&r,&c)!=EOF)
	{
		if(r==0 && c==0)
			break;
		else
		{
			scanf("%d",&start);
			for(i=0;i<r;i++)
				scanf("%s",grid[i]);
			memset(vis,0,sizeof(vis));
			dfs(0,start-1,0);
		}
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值