poj 1573 Robot Motion

9 篇文章 0 订阅
A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

【题意】给你一个图,图中每个点都有自己的方向,问你从某一个点出发,不限时间的走这张图,最后的结果是啥,显然结果只有两种,从图中出来了,输出走出来用的时间,或者陷入了死循环,输出循环的步数和进入循环之前的步数。

【分析】就是一个模拟题,按着他给的方向走就行,如果走到了某个地方发现这个地方来过就说明这是个死循环,跳出循环就行,我做的方法是直接定义一个死循环,让他一直走,跳出循环的条件就是走出了图或者走到了某个走过的地方。

【代码】

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int changex[]= {0,0,1,-1};
int changey[]= {1,-1,0,0};
int lenx,leny,sx,sy;
int mat[15][15];//记录图
int ans[15][15];//记录到某个地方用的时间,如果为0表示没有来过
char xx;
int main()
{
//    freopen("in.txt","r",stdin);
    while(scanf("%d%d%d",&lenx,&leny,&sy)!=EOF&&lenx&&leny&&sy)
    {
        sx=1;//初始化起点
        for(int i=1; i<=lenx; i++)
            for(int j=1; j<=leny; j++)
            {
                scanf(" %c",&xx);//我这里直接转换了一下,和changex,changey同步了,免得处理字符
                if(xx=='E')
                    mat[i][j]=0;
                else if(xx=='W')
                    mat[i][j]=1;
                else if(xx=='S')
                    mat[i][j]=2;
                else if(xx=='N')
                    mat[i][j]=3;
            }
        memset(ans,0,sizeof(ans));//初始化所有的节点都没有到达
        int step=0,loop=0;
        int cha;
        while(1)
        {
            step++;
            ans[sx][sy]=step;
            cha=mat[sx][sy];//记录方向
            sx+=changex[cha];
            sy+=changey[cha];
            if(sx<1||sx>lenx||sy<1||sy>leny)//跳出图
                break;
            if(ans[sx][sy])//陷入死循环
            {
                loop=step-ans[sx][sy]+1;
                step=ans[sx][sy]-1;
                break;
            }
        }
        if(loop)
            printf("%d step(s) before a loop of %d step(s)\n",step,loop);
        else
            printf("%d step(s) to exit\n",step);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zuhiul

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值