ACboy needs your help
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2108 Accepted Submission(s): 1067
Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
Sample Input
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
Sample Output
3 4 6
Source
Recommend
lcy
简单的分组背包问题
#include<stdio.h>
#include<string.h>
#define MAXN 101
int a[MAXN][MAXN];
int f[MAXN];
int main(void)
{
int N,M;
// freopen("d:\\in.txt","r",stdin);
while(scanf("%d%d",&N,&M),N||M)
{
int i,j,k;
for(i=1;i<=N;i++)
for(j=1;j<=M;j++)
scanf("%d",&a[i][j]);
memset(f,0,sizeof(f));
for(i=1;i<=N;i++)
for(j=M;j>=1;j--)
{
for(k=1;k<=j;k++)
{
f[j]=f[j-k]+a[i][k]>f[j]?f[j-k]+a[i][k]:f[j];
}
}
printf("%d\n",f[M]);
}
return 0;
}