gdufe acm 1011 Prime Ring Problem

链接:http://acm.gdufe.edu.cn/Problem/read/id/1011

Problem Description:

     A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1.

Input:

n (0 < n < 20).

Output:

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case even if there is no answer.
Sample Input:

6
8
Sample Output:

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

代码:


#include <stdio.h>
#include <string.h>
int vis[20];
int se[20];
int is_prime[40];
int n;
void dfs(int x,int s){
    if(s==n){
        if(is_prime[x+1]){
        printf("%d",se[1]);
        for(int i=2;i<=n;i++)
            printf(" %d",se[i]);
        printf("\n");
        }
        return ;
    }
    for(int i=1;i<=n;i++){
        if(i!=x && vis[i]==0 && is_prime[i+x]){
            vis[i]=1;
            se[s+1]=i;
            dfs(i,s+1);
            vis[i]=0;
        }
    }
}
int main(){
    int cnt=1;
    int maxn=40;
    for(int i=2;i<maxn;i++)
        is_prime[i]=1;
    for(int i=2;i*i<maxn;i++){
        for(int j=i*2;j<maxn;j++){
            if(is_prime[j]&&j%i==0){
                is_prime[j]=0;
            }
        }
    }//筛出40内的素数
    while(scanf("%d",&n)==1){
        printf("Case %d:\n",cnt++);
        if(n%2==0){
        memset(vis,0,sizeof(vis));
        memset(se,0,sizeof(se));
        se[1]=1;
        vis[1]=1;//已访问
        dfs(1,1);
        }
        printf("\n");
    }
    return 0;
}

我用dfs解本题时,TE了N发。

后来才发现:
若n为奇数,为了满足相邻相数互质,只能按“奇-偶-奇-偶-奇…”排列(奇数+奇数=偶数),显然第n个数是奇数,而第1个数1是奇数,奇数+1=偶数,综上,n为奇数时无解。

然后,就AC了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值