杭电 HDU ACM 1016 Prime Ring Problem

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31900    Accepted Submission(s): 14108


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
 
 
又一个深搜题目!并且这个素数环问题 参考了 人家的优化方案,值得好好吸收。搜索过程可以从实际问题中抽象而不是单纯的 ”矩阵给出“。奇偶性剪枝也要时刻注意。
#include<iostream>
#include<string.h>
#include<list>
using namespace std;

int prime[41],visited[21],step,n;
list<int>cnt;
void Prime()             // 素数打表判定
{
    memset(prime,0,sizeof(prime));
    for(int i=2; i<=41; i++)
    {
        if(!prime[i])
        {
            for(int j=i+i; j<=41; j+=i)
                prime[j]=1;
        }
    }
    prime[1]=1;
}

void dfs(int k)
{

    if(step==n&&!prime[k+1])  //某次搜索结束条件,也即如果出现某条满足题意搜索,输出即可
    {
        cout<<1;
        for(list<int>::iterator it=cnt.begin(); it!=cnt.end(); it++)
            cout<<" "<<(*it);
        cout<<endl;
        return ;
    }
    else if(k&1)         //如果为奇数,那么为了和下一个数的加和为素数,只能在奇数中搜索
    {
        for(int i=2; i<=n; i+=2)
        {
            if(!visited[i]&&!prime[k+i])//如果某个结点未搜索过,且满足和k加和为素数
            {
                cnt.push_back(i);
                visited[i]=1;  //标记已被访问
                step++;
                dfs(i);
                visited[i]=0;//回溯到上次结点处
                step--;
                cnt.pop_back();
            }
        }

    }
    else if(!(k&1))
    {
        for(int p=3; p<=n; p+=2)
        {
            if(!visited[p]&&!prime[p+k])
            {
                cnt.push_back(p);
                visited[p]=1;
                step++;
                dfs(p);
                visited[p]=0;
                step--;
                cnt.pop_back();

            }
        }
    }
    return ;
}

int main()
{
    int t=0;
    while(cin>>n)
    {
        cout<<"Case "<<++t<<":"<<endl;
        memset(visited,0,sizeof(visited));
        Prime();
//        if(n&1)
//            continue;
        visited[1]=1;
        step=1;
        dfs(1);
        cnt.clear();
        cout<<endl;

    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值