二进制加构造思维

1 篇文章 0 订阅
1 篇文章 0 订阅

Binary Tree

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1049 Accepted Submission(s): 620
Special Judge

Problem Description
The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.

Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 1. Say froot=1.

And for each node u, labels as fu, the left child is fu×2 and right child is fu×2+1. The king looks at his tree kingdom, and feels satisfied.

Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another N years, only if he could collect exactly N soul gems.

Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node x, the number at the node is fx (remember froot=1), he can choose to increase his number of soul gem by fx, or decrease it by fx.

He will walk from the root, visit exactly K nodes (including the root), and do the increasement or decreasement as told. If at last the number is N, then he will succeed.

Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.

Given N, K, help the King find a way to collect exactly N soul gems by visiting exactly K nodes.

Input
First line contains an integer T, which indicates the number of test cases.

Every test case contains two integers N and K, which indicates soul gems the frog king want to collect and number of nodes he can visit.

⋅ 1≤T≤100.

⋅ 1≤N≤109.

⋅ N≤2K≤260.

Output
For every test case, you should output “Case #x:” first, where x indicates the case number and counts from 1.

Then K lines follows, each line is formated as ‘a b’, where a is node label of the node the frog visited, and b is either ‘+’ or ‘-’ which means he increases / decreases his number by a.

It’s guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.

Sample Input
2
5 3
10 4

Sample Output
Case #1:
1 +
3 -
7 +
Case #2:
1 +
3 +
6 -
12 +
题意:要求你在一颗满二叉树上求一条路径,这条路径上从二叉树上的第一层到第K层,每层一个点,每个点上的值可以加也可以减,要使最终的值的和为N,开始为0.

解题思路:要注意到一个条件N≤2^K≤2^60.也就是我们可以沿着二叉树最左边往下走,但是这样走可以保证值不会小于N,但是可能大于N,所以我们要把大于N的那部分减掉就行。

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
ll N;
int K;
bool flag[100];
ll getValue(int i)
{
    ll ans = 1;
    ll term = 2;
    while(i)
    {
        if(i&1) ans *= term;
        i >>= 1;
        term = term*term;
    }
    return ans;
}
int main()
{
    int T;
    scanf("%d",&T);
    for(int ca = 1; ca <= T; ca++)
    {
        memset(flag,false,sizeof(flag));
        scanf("%lld%d",&N,&K);
        printf("Case #%d:\n",ca);
        if(N == getValue(K))
        {
            ll x = 1;
            for(int i = 1; i < K; i++)
            {
                printf("%lld +\n",x);
                x <<= (ll)1;
            }
            printf("%lld +\n",x + 1);
        }
        else
        {
            ll sum;
            if(N&1)
            {
                sum = getValue(K) - 1;
                sum -= N;
                sum >>= 1;
                int res = -1;
                while(sum)
                {
                    res++;
                    if(sum&1) flag[res] = true;
                    sum >>= 1;
                }
                for(int i = 0; i < K; i++)
                {
                    if(flag[i]) printf("%lld -\n",getValue(i));
                    else printf("%lld +\n",getValue(i));
                }

            }
            else
            {
                sum = getValue(K);
                sum -= N;
                sum >>= 1;
                int res = -1;
                while(sum)
                {
                    res++;
                    if(sum&1) flag[res] = true;
                    sum >>= 1;
                }
                for(int i = 0; i < K - 1; i++)
                {
                    if(flag[i]) printf("%lld -\n",getValue(i));
                    else printf("%lld +\n",getValue(i));
                }
                printf("%lld +\n",getValue(K - 1) + 1);
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值