HDU6030(矩阵快速幂)

Happy Necklace

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 274 Accepted Submission(s): 111

Problem Description
Little Q wants to buy a necklace for his girlfriend. Necklaces are single strings composed of multiple red and blue beads.
Little Q desperately wants to impress his girlfriend, he knows that she will like the necklace only if for every prime length continuous subsequence in the necklace, the number of red beads is not less than the number of blue beads.
Now Little Q wants to buy a necklace with exactly n beads. He wants to know the number of different necklaces that can make his girlfriend happy. Please write a program to help Little Q. Since the answer may be very large, please print the answer modulo 109+7.
Note: The necklace is a single string, {not a circle}.

Input
The first line of the input contains an integer T(1≤T≤10000), denoting the number of test cases.
For each test case, there is a single line containing an integer n(2≤n≤1018), denoting the number of beads on the necklace.

Output
For each test case, print a single line containing a single integer, denoting the answer modulo 109+7.

Sample Input
2
2
3

Sample Output
3
4

解题思路:我们可以得出递推式f[i] = f[i - 1] + f[i - 3],直接快速幂就行。

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const ll mod = 1e9 + 7;
ll n;
struct Matrix{
    ll v[3][3];
};
Matrix Matrix_mul(Matrix m1,Matrix m2)
{
    Matrix ans;
    for(int i = 0; i <= 2; i++)
    {
        for(int j = 0; j <= 2; j++)
        {
            ans.v[i][j] = 0;
            for(int k = 0; k <= 2; k++)
            {
                ans.v[i][j] += (m1.v[i][k]*m2.v[k][j])%mod;\
                ans.v[i][j] %= mod;
            }
        }
    }
    return ans;
}
Matrix Matrix_pow(ll i,Matrix x)
{
    Matrix ans = {1,0,0,0,1,0,0,0,1};
    while(i)
    {
        if(i&1) ans = Matrix_mul(x,ans);
        i >>= 1;
        x = Matrix_mul(x,x);
    }
    return ans;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld",&n);
        if(n == 2)
        {
            printf("3\n");
            continue;
        }
        if(n == 3)
        {
            printf("4\n");
            continue;
        }
        if(n == 4)
        {
            printf("6\n");
            continue;
        }
        Matrix term1 = {6,0,0,4,0,0,3,0,0};
        Matrix term2 = {1,0,1,1,0,0,0,1,0};
        ll d = n - 4;
        term2 = Matrix_pow(d,term2);
        term1 = Matrix_mul(term2,term1);
        printf("%lld\n",term1.v[0][0]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值