HDU3530(单调队列)

Subsequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6679 Accepted Submission(s): 2243

Problem Description
There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.

Input
There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.

Output
For each test case, print the length of the subsequence on a single line.

Sample Input
5 0 0
1 1 1 1 1
5 0 3
1 2 3 4 5

Sample Output
5
4

题意:给你N个数,让你找出一个最长的连续子序列,这个子序列的最大值和最小值的差值介于m,k之间。

解题思路:用两个单调队列,一个维护最大值,一个维护最小值,当最大值与最小值的差值大于k时,考虑把最大值变小,或者把最小值变大,具体看最大值与最小值的位置关系。、

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e5 + 10;
int qmax[maxn];//维护最大值的队列
int qmin[maxn];//维护最小值的队列
int lmax, rmax;
int lmin, rmin;//l 表示队尾,r表示队首
int n, m, k;
int a[maxn];
int ans;
void init()
{
    lmax = lmin = 0;
    rmin = rmax = 0;
    ans = 0;
}
int main()
{
    while(~scanf("%d%d%d", &n, &m, &k))
    {
        init();
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
        }
        int l1 = 0;
        int l2 = 0;
        bool flag = false;
        for(int i = 1; i <= n; i++)
        {
            while(rmax > lmax && a[qmax[rmax - 1]] <= a[i]) rmax--;
            qmax[rmax++] = i;
            while(rmin > lmin && a[qmin[rmin - 1]] >= a[i]) rmin--;
            qmin[rmin++] = i;
            while(a[qmax[lmax]] - a[qmin[lmin]] > k)
            {
                if(qmax[lmax] > qmin[lmin]) l2 = qmin[lmin++];
                else l1 = qmax[lmax++];
            }
            if(a[qmax[lmax]] - a[qmin[lmin]] >= m && a[qmax[lmax]] - a[qmin[lmin]] <= k)
            {
                ans = max(ans,i - max(l1,l2));
                flag = true;
            }
        }
        if(flag)
        printf("%d\n", ans);
        else printf("0\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值