HDU1532(最大流Dinic算法模板题)

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17510 Accepted Submission(s): 8245

Problem Description
Every time it rains on Farmer John’s fields, a pond forms over Bessie’s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie’s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output
50

Source
USACO 93

最近在学网络流,昨天学了EK算法求最大流,今天学了Dinic算法求最大流,其实这两者算法都是在本质上一样的,都是利用反向边和不断寻找增广路径来实现最大流的,只是EK算法是一条一条的寻找增广路径,直到找不到为止,而Dinic算法是利用dfs一次可以找多条增广路径,另外,Dinic算法中增加了在“层次”的概念,就是源点到该点的边数,用dfs寻找增广路径时严格按照层次依次增大来向后找直到找到汇点为止。下面是我Dinic算法的ac代码。如果你想看EK算法的代码,可以看我上一篇博客,里面有我对EK算法的理解和图解,希望对你有帮助。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 205;
const int inf = 1e9;
int N, M;
bool visit[maxn];
int Level[maxn];//每个点的层次
int head[maxn];
int cnt;
int Maxflow;
int Map[maxn][maxn];
struct edge{
    int u, v;
    int f;
    int last;
}Edge[4 * maxn];
void add(int u, int v, int f)
{
    Edge[cnt].u = u;
    Edge[cnt].v = v;
    Edge[cnt].f = f;
    Edge[cnt].last = head[u];
    head[u] = cnt++;//添加正向边
    Edge[cnt].u = v;
    Edge[cnt].v = u;
    Edge[cnt].f = 0;
    Edge[cnt].last = head[v];
    head[v] = cnt++;//添加正向边
}
bool bfs(int s, int t)//重建网络
{
    memset(visit, false, sizeof(visit));
    Level[s] = 1;
    queue<int> Q;
    Q.push(s);
    while(!Q.empty())
    {
        int u = Q.front();
        if(u == t) return true;
        Q.pop();
        visit[u] = true;
        for(int i = head[u]; i != -1; i = Edge[i].last)
        {
            int v = Edge[i].v;
            int f = Edge[i].f;
            if(!visit[v] && f)
            {
                visit[v] = true;
                Level[v] = Level[u] + 1;
                Q.push(v);
            }
        }
    }
    return false;
}
int dfs(int s, int flow, int t)
{
    if(s == t) return flow;
    int res = 0;
    for(int i = head[s]; i != -1; i = Edge[i].last)
    {
        int v = Edge[i].v;
        int term = min(flow - res, Edge[i].f);
        if(term && Level[v] == Level[s] + 1)
        {
            int f = dfs(v, term, t);
            Edge[i].f -= f;//正向边减少
            Edge[i + 1].f += f;//反向增加
            res += f;
            if(res == flow) return res;
        }

    }
    return res;
}
void init()
{
    memset(Level, 0 ,sizeof(Level));
    memset(head, -1, sizeof(head));
    memset(Map, 0, sizeof(Map));
    cnt = Maxflow = 0;
}
void Dinic(int s, int t)
{
    while(bfs(s, t)) Maxflow += dfs(s, inf, t);
}
int main()
{
    while(~scanf("%d%d", &N, &M))
    {
        int u, v, f;
        init();
        for(int i = 1; i <= N; i++)
        {
            scanf("%d%d%d", &u, &v, &f);
            Map[u][v] += f;
        }
        for(int i = 1; i <= M; i++)
        {
            for(int j = 1; j <= M; j++)
            {
                if(Map[i][j])
                {
                    add(i, j, Map[i][j]);
                }
            }
        }
        Dinic(1, M);
        printf("%d\n", Maxflow);
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值