red and black

 

 

red and black

Time Limit:1000MS  Memory Limit:65536K
Total Submit:91 Accepted:49

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

 

 

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

 

 

45
59
6
13

Source

#include<iostream>
#include<queue>
using namespace std;
struct zuobiao//坐标千万不能搞错
{
 int x,y;
}r,t;
int main()
{ queue<zuobiao> q; 
 int m,n,i,j,f1,f2,f3,f4,g1,g2,g3,g4,s;
 while(cin>>m>>n&&(m||n))
 { char a[21][21]={'/0'};//赋初值
  s=0;
  while(!q.empty())
   q.pop();//清空队列
  getchar();
  for(i=0;i<n;i++)
  {
   gets(a[i]);
  }
  for(i=0;i<n;i++)
  { 
   for(j=0;j<m;j++)
   {
    if(a[i][j]=='@')
    {
     a[i][j]='1';
     r.x=i;
     r.y=j;
     q.push(r);
     s++;
    }
   }
  }
  //cout<<a[r.x][r.y]<<endl;
  //cout<<r.x<<r.y<<endl;
  while(q.empty()!=true)
  {
   t=q.front();
   f1=t.x-1;
   g1=t.y;
   f2=t.x+1;
   g2=t.y;
   f3=t.x;
   g3=t.y-1;
   f4=t.x;
   g4=t.y+1;
   //cout<<f1<<g1<<" "<<f2<<g2<<" "<<f3<<g3<<" "<<f4<<g4<<endl;
   //cout<<a[f1][g1];
   if(a[f1][g1]=='.')
   {
    a[f1][g1]='1';
    r.x=f1;
    r.y=g1;
    q.push(r);
    s++;
   }
   if(a[f2][g2]=='.')
   {
    a[f2][g2]='1';
    r.x=f2;
    r.y=g2;
    q.push(r);
    s++;
   }
   if(a[f3][g3]=='.')
   {
    a[f3][g3]='1';
    r.x=f3;
    r.y=g3;
    q.push(r);
    s++;
   }
   if(a[f4][g4]=='.')
   {
    a[f4][g4]='1';
    r.x=f4;
    r.y=g4;
    q.push(r);
    s++;
   }
   q.pop();
  }
  cout<<s<<endl; 
 }
return 0;
}
 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值