A - Red and Black(3.2.1)

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
代码:
#include <iostream>
#include <cstdio>
using namespace std;
int cnt,n,m;
char map[30][30];
int doto[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
void df(int i,int j)
{
    cnt++;
    map[i][j]='#';//每次搜索完毕就赋值为‘#’,避免重复累加
    //对于每一点,对其上下左右都进行搜索一遍
    for(int k=0;k<4;k++)
    {
        int x=i+doto[k][0];
        int y=j+doto[k][1];
        if(x<n&&y<m&&x>=0&&y>=0&&map[x][y]=='.')//如果是黑砖则继续对黑砖进行四周搜索
            df(x,y);
    }
    return ;

}
int main()
{
    int fi;
    int fj;
    while(cin>>m>>n)
    {
        if(n==0&&m==0)
            break;
        int i;
        for(i=0;i<n;i++)
        {
            int j;
            for(j=0;j<m;j++)
            {
                cin>>map[i][j];
            if(map[i][j]=='@')//记录初始位置
               {

                   fi=i;
                   fj=j;
               }
            }

        }
        cnt=0;
        df(fi,fj);//从最初的位置进行搜索
        cout<<cnt<<endl;
    }
    return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值