Oil Deposits

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output
0
1
2

2

GeoSurvComp地质勘测公司负责检测地下油藏。 GeoSurvComp一次可以与一个大的矩形区域一起工作,并创建一个将土地划分成多个方块的网格。然后分析每个地块,使用感测设备来确定地块是否含有油。含油的情节叫做口袋。如果两个口袋相邻,那么它们是相同油层的一部分。油藏可能相当大,可能包含许多口袋。你的工作是确定一个电网中有多少不同的油藏。
输入
输入文件包含一个或多个网格。每个网格以包含m和n的行开始,网格中的行数和列数由单个空格分隔开。如果m = 0,它会显示输入的结尾;否则1 <= m <= 100,1 <= n <= 100.以下是每行n个字符的m行(不计算行尾字符)。每个字符对应一个图,它是“*”,表示没有油,或者“@”表示油袋。
输出
对于每个电网,输出不同油层的数量。如果水平,垂直或对角相邻,两个不同的口袋是相同油层的一部分。一个油藏不会超过100个口袋。
样品输入
1 1
*
3 5
* @ * @ *
** ** @
* @ * @ *
1 8
@@ **** @ *
5 5
**** @
* @@ * @
* @ ** @
@@@ * @
@@ ** @
0 0
样品输出
0
1
2
2



#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int MAX = 1e2+10;//限定一个变量不允许被改变 
typedef long long LL;
char a[MAX][MAX]; 
int n,m,v[MAX][MAX],ans;
int fx[8]={0,0,-1,1,-1,1,-1,1},fy[8]={1,-1,0,0,1,1,-1,-1};
void dfs(int x,int y)
{
	v[x][y]=1;//标记一下,代表走过了
	for(int i=0;i<8;i++)
	{
		int xx=x+fx[i],yy=y+fy[i];//表示朝向不同的方向走 
		if(xx >=0 && yy>=0 &&xx<=n&&yy<=m&&!v[xx][yy]&&a[xx][yy]=='@') // 判断是否出界, 是否已经搜索过, 是否为油田 
            // 判断是否越界,x,y 的下界都是 0 ,上界分别 是 n,m
		dfs(xx,yy);
	} 
}
int main()
{
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		if(n==0&&m==0)
		break;
		memset(v,0,sizeof(v));//把v里的数全部替换为零 ,头文件为<string.h> 
		for(int i=0;i<n;i++)
		scanf("%s",a[i]);
		ans=0;
		for(int i=0;i<n;i++)
		for(int j=0;j<m;j++)
		if(!v[i][j] && a[i][j] == '@')
                    ans++,dfs(i,j); // 第一次搜到 + 1 
                    printf("%d\n",ans);
	}
		return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值