HDU2709||Sumsets

link:http://acm.hdu.edu.cn/showproblem.php?pid=2709

    Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

整数递推,这个题从1开始,结果依次为 1 2 2 4 4 6 6 10 10 14 14 20 20 26 26 36 36 46 46 60 60 74

可以看出当这个数是奇数x时,a[x]=a[x-1]

偶数时,a[x]=a[x-2]+a[x/2]

因为题目限制输出后九位,所以都要对1e9取余
AC代码:

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
const int N=1000100;
int mod=1000000000;
int a[N];
void fun()
{
    int i;
    a[1]=1;
    a[2]=2;
    for(i=3;i<N;i++)
    {
        if(i%2==1)
            a[i]=a[i-1]%mod;
        else
            a[i]=(a[i-2]+a[i/2])%mod;
    }
}
int main()
{
    int n;
    fun(); 
    while(~scanf("%d",&n))
    printf("%d\n",a[n]);
return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

三更鬼

谢谢老板!

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值