myeclipse8.5添加tomcat8.0

JAVA Web 专栏收录该内容
5 篇文章 0 订阅

今天练习时想在myeclipse8.5上使用tomcat7.0,但是发现windows→preference→servers→tomcat里并没有tomcat 7.x,所以就需要咱们手动加入tomcat7.0了

,步骤如下:

1、找到tomcat配置位置:

注意要先配置tomcat7.0的文件位置,否则直接点击create launch configuration会出现下面的情况:所以一定要记得先添加上tomcat'7.0的文件

2、在tomcat6.x处添加tomcat 7.0的文件,并设置成enable,设置完之后记得点击apply;

3、点击create launch configuration会出现下面页面,可以自己修改name,在classpath中点击add external jars 添加入tomcat-juli.jar文件,点击apply:

至此,tomcat7.0已经配置好,启动tomcat,在浏览器中输入localhost:8080又可以看到那只熟悉的小猫了、

然而,如果再Myeclipse中运行Tomcat服务器时报错,则说明内置的JDK是1.6版本的,而安装的tomcat版本是8.0的,需要更高版本的JDK来支持。解决方案如下

       windows→Preferences→MyEclipseEnterprise Workbench→Servers→Tomcat(由于MyEclipse没有提供Tomcat8.x的服务选项,就用tomcat5.x添加运行tomcat8)

1、将Tomcat server设置为Enable。

2、在Tomcat home directory点击browser选择tomcat的安装路径(E:\tomcat8.5.9)

3、在Tomcat5.x下的JDK目录,在后边"Tomcat JDK name"出点击"add"按钮,添加JDK,在弹出的窗口点"Browse"找到安装路径,点击"ok"。如图所示: 

点击Paths目录,在右边Prepend to classpath 和Append to classpath处点击"Add JAR/ZIP",添加jar包tomcat-juli.jar。点击"ok"

相关配置成功之后,Servlet可以成功运行,在浏览器中输入localhost:8080测试。

  • 5
    点赞
  • 0
    评论
  • 22
    收藏
  • 打赏
    打赏
  • 扫一扫,分享海报

参与评论 您还未登录,请先 登录 后发表或查看评论
©️2022 CSDN 皮肤主题:书香水墨 设计师:CSDN官方博客 返回首页

打赏作者

相册的记忆

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值