1028. List Sorting (25)
Excel can sort records according to any column. Now you are supposed to imitate this function.
Input
Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).
Output
For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.
Sample Input 13 1 000007 James 85 000010 Amy 90 000001 Zoe 60Sample Output 1
000001 Zoe 60 000007 James 85 000010 Amy 90Sample Input 2
4 2 000007 James 85 000010 Amy 90 000001 Zoe 60 000002 James 98Sample Output 2
000010 Amy 90 000002 James 98 000007 James 85 000001 Zoe 60Sample Input 3
4 3 000007 James 85 000010 Amy 90 000001 Zoe 60 000002 James 90Sample Output 3
000001 Zoe 60 000007 James 85 000002 James 90 000010 Amy 90
- #include <iostream>
- #include <string>
- #include <algorithm>
- #include <memory.h>
- #include <cstdio>
- #include <cstdlib>
- #include <queue>
- #include <vector>
- using namespace std;
- #define MAX 0Xfffffff
- int c;
- struct Node{
- char id[10];
- int grade;
- char name[14];
- bool operator<(const Node& node)const{
- if(c==1){
- return strcmp(id, node.id)<0;
- }else if(c==2){
- if(strcmp(name, node.name))
- return strcmp(name, node.name)<0;
- return strcmp(id, node.id)<0;
- }else{
- if(grade!=node.grade)
- return grade<node.grade;
- return strcmp(id, node.id)<0;
- }
- }
- };
- Node nodes[100001];
- int main(){
- //freopen("in.txt", "r", stdin);
- int n;
- while(cin>>n>>c){
- for(int i=0;i<n;++i){
- scanf(" %s %s %d", nodes[i].id, nodes[i].name, &nodes[i].grade);
- }
- sort(nodes, nodes+n);
- for(int i=0;i<n;++i){
- printf("%s %s %d\n", nodes[i].id, nodes[i].name, nodes[i].grade);
- }
- }
- //fclose(stdin);
- }