1028. List Sorting (25)

1028. List Sorting (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3
 
 
000001 Zoe 60 000007 James 85 000002 James 90 000010 Amy 90
这道题如果用cin cout,最后一个测试点会运行超时过不了,改用scanf和printf,但是scanf与printf不能直接处理string类,对字符串的处理是用char*实现,如果要用string类的话,是scanf("%s",&str[0]);printf("%s",str.data());.
#include<iostream>
#include<fstream>
#include<string>
#include<algorithm>
#include<vector>
using namespace std;
struct STUDENT
{
	string id;
	string name;
	int grade;
};
bool CompA(STUDENT a, STUDENT b)
{
	return a.id < b.id;
}
bool CompB(STUDENT a, STUDENT b)
{
	if (a.name != b.name)return a.name < b.name;
	else return a.id < b.id;

}
bool CompC(STUDENT a, STUDENT b)
{
	if (a.grade != b.grade)return a.grade < b.grade;
	else return a.id < b.id;
}
int main()
{
	
	
	int N, C;
	//fin >> N >> C;
	scanf("%d%d\n", &N, &C);
	int i;
	STUDENT st;
	st.id.resize(7);
	st.name.resize(9);
	vector<STUDENT>List;
	for (i = 0; i < N; i++)
	{
		//fin >> st.id >> st.name >> st.grade;
		scanf("%s%s%d", &st.id[0], &st.name[0], &st.grade);
		List.push_back(st);
	}
	switch (C)
	{case 1:
		sort(List.begin(), List.end(), CompA);
		break;
	case 2:
		sort(List.begin(), List.end(), CompB);
		break;
	case 3:
		sort(List.begin(), List.end(), CompC);
		break;
	}
	for (i = 0; i < N; i++)
		printf("%s %s %d\n", List[i].id.data(), List[i].name.data() ,List[i].grade);
		//cout << List[i].id << " " << List[i].name << " " << List[i].grade<<endl;

	
	
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值