POJ 2195 Going Home(解题报告)

Description

On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man. Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point.
You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

Input

There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

Output

For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

Sample Input

2 2
.m
H.
5 5
HH..m
.....
.....
.....
mm..H
7 8
...H....
...H....
...H....
mmmHmmmm
...H....
...H....
...H....
0 0

Sample Output

2
10
28

二分图匹配求最小值,因为原方法求的是最大值,那将每条边转换为负值,所求最大值实际上就转换为了求最小值。

#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<string.h>
bool vx[100],vy[100];
#define MAX -(0xfffffff)
int match[100],map[100][100],lx[100],ly[100],n,lack[100];
char map1[100][101];
struct house
{
	int x,y;
}h[100];
struct man
{
	int x,y;
}M[100];
bool hungray(int i)
{
	int j;
	vx[i]=1;
	for(j=0;j<n;j++)
	{
		if(vy[j])
			continue;
		if(lx[i]+ly[j]==map[i][j])
		{
			vy[j]=1;
			if(match[j]==-1||hungray(match[j]))
			{
				match[j]=i;
				return 1;
			}
		}
		else if(lx[i]+ly[j]-map[i][j]<lack[j])
			lack[j]=lx[i]+ly[j]-map[i][j];
	}
	return 0;
}
int km()
{
	int i,j,d;
	memset(ly,0,sizeof(ly));
	memset(match,-1,sizeof(match));
	for(i=0;i<n;i++)
	{
		lx[i]=MAX;
		for(j=0;j<n;j++)
			if(map[i][j]>lx[i])
				lx[i]=map[i][j];
	}
	for(i=0;i<n;i++)
	{
		for(j=0;j<n;j++)
			lack[j]=-MAX;
		while(1)
		{
			memset(vx,0,sizeof(vx));
			memset(vy,0,sizeof(vy));
			if(hungray(i))
				break;
			d=-MAX;
			for(j=0;j<n;j++)
				if(!vy[j]&&lack[j]<d)
					d=lack[j];
			for(j=0;j<n;j++)
			{
				if(vx[j])
					lx[j]-=d;
				if(vy[j])
					ly[j]+=d;
				else
					lack[j]-=d;
			}
		}
	}
	d=0;
	for(i=0;i<n;i++)
		d+=(lx[i]+ly[i]);
	return -d;
}
int main()
{
	int N,m;
	while(scanf("%d%d",&N,&m)!=EOF&&N&&m)
	{
		int i,j;
		int allm=0,allh=0;
		for(i=0;i<N;i++)
			scanf("%s",map1[i]);
		for(i=0;i<N;i++)
			for(j=0;j<m;j++)
				if(map1[i][j]=='m')
				{
					M[allm].x=i;
					M[allm++].y=j;
				}
				else if(map1[i][j]=='H')
				{
					h[allh].x=i;
					h[allh++].y=j;
				}
		n=allm;
		for(i=0;i<allm;i++)
			for(j=0;j<allh;j++)
				map[i][j]=-abs(M[i].x-h[j].x)-abs(M[i].y-h[j].y);
		printf("%d\n",km());
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值