数据结构实验之二叉树的建立与遍历

http://acm.sdut.edu.cn/sdutoj/showproblem.php?pid=2136&cid=1794

数据结构实验之二叉树的建立与遍历

Time Limit: 1000MS Memory limit: 65536K

题目描述

       已知一个按先序序列输入的字符序列,如abc,,de,g,,f,,,(其中逗号表示空节点)。请建立二叉树并按中序和后序方式遍历二叉树,最后求出叶子节点个数和二叉树深度。

输入

  输入一个长度小于50个字符的字符串。

输出

输出共有4行:
第1行输出中序遍历序列;
第2行输出后序遍历序列;
第3行输出叶子节点个数;
第4行输出二叉树深度。

示例输入

abc,,de,g,,f,,,

示例输出

cbegdfacgefdba35

#include <stdio.h>
#include <stdlib.h>
typedef char type;
typedef struct tnode
{
   type data;
   tnode *lc;
   tnode *rc;
}tnode,*tree;
int leaf=0,depth;
tree creat(tree &T)
{
    char s;
    scanf("%c",&s);
    if(s==',')
        T=NULL;
    else
    {
        T=(tree)malloc(sizeof(tnode));
        T->data=s;
        T->lc=creat(T->lc);
        T->rc=creat(T->rc);
    }
    return T;
}
void midorder(tree T)
{
   if(T!=NULL)
   {
      midorder(T->lc);
      printf("%c",T->data);
      midorder(T->rc);
   }
}
void hinorder(tree T)
{
    if(T!=NULL)
    {
       hinorder(T->lc);
       hinorder(T->rc);
       printf("%c",T->data);
    }
}
void countleaf(tree T)
{
    if(T)
    {
        if(T->lc==NULL&&T->rc==NULL)
            leaf++;
        else
        {
            countleaf(T->lc);
            countleaf(T->rc);
        }
    }
}
int countdepth(tree T)
{
    int ldepth,rdepth;
    if(!T)
        return 0;
    else
    {
        if(T->lc)
            ldepth=countdepth(T->lc);
        else
            ldepth=0;
        if(T->rc)
            rdepth=countdepth(T->rc);
        else
            rdepth=0;
        return ldepth>rdepth?ldepth+1:rdepth+1;
    }
}
int main()
{
    tree T;
    T=creat(T);
    midorder(T);
    printf("\n");
    hinorder(T);
    printf("\n");
    countleaf(T);
    depth=countdepth(T);
    printf("%d\n%d\n",leaf,depth);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
建立一棵二叉树,我们可以利用二叉链表作为存储结构。二叉链表的节点包含三个字段:data(存储节点的数据)、left(指向左子树的指针)和right(指向右子树的指针)。 首先,我们可以定义一个二叉树节点的结构体: struct TreeNode { int data; TreeNode* left; TreeNode* right; }; 然后,我们可以使用该结构体创建二叉树节点,并根据需要设置节点的data、left和right字段。例如,我们可以创建根节点和两个子节点,然后将它们彼此连接起来,形成一棵二叉树。 TreeNode* root = new TreeNode(); // 创建根节点 root->data = 1; // 设置根节点的数据 TreeNode* leftChild = new TreeNode(); // 创建左子节点 leftChild->data = 2; // 设置左子节点的数据 TreeNode* rightChild = new TreeNode(); // 创建右子节点 rightChild->data = 3; // 设置右子节点的数据 root->left = leftChild; // 将左子节点连接到根节点的左指针 root->right = rightChild; // 将右子节点连接到根节点的右指针 这样,我们就成功建立一棵简单的二叉树。 根据题目要求,这棵二叉树还需要进行遍历。常见的二叉树遍历方式有三种:前序遍历、中序遍历和后序遍历。下面以前序遍历为例,给出算法的伪代码: void PreorderTraversal(TreeNode* root) { if (root != NULL) { // 遍历根节点 cout << root->data << " "; // 遍历左子树 PreorderTraversal(root->left); // 遍历右子树 PreorderTraversal(root->right); } } 在实际应用中,我们可以调用PreorderTraversal函数来执行二叉树的前序遍历,并按照规定的格式输出遍历结果。 总而言之,建立二叉树的过程只需创建节点并连接它们,然后利用递归算法对树进行遍历即可。以上是二叉树建立和前序遍历的基本步骤和示例代码。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值