数据结构实验之二叉树四:还原二叉树

http://acm.sdut.edu.cn/sdutoj/showproblem.php?pid=3343&cid=1796

数据结构实验之二叉树四:还原二叉树

Time Limit: 1000MS Memory limit: 65536K

题目描述

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

输入

输入数据有多组,每组数据第一行输入 1 个正整数 N(1 <= N <= 50) 为树中结点总数,随后 2 行先后给出先序和中序遍历序列,均是长度为 N 的不包含重复英文字母 ( 区分大小写 ) 的字符串。

输出

  输出一个整数,即该二叉树的高度。

示例输入

9 
ABDFGHIEC
FDHGIBEAC

示例输出

5

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<iostream>
#include<queue>
using namespace std;
typedef char type;
typedef struct tnode
{
    struct tnode *lc;
    struct tnode *rc;
    type data;
}tnode,*tree;
tree creat(char *bef,char *mid,int len)
{
    tree T;
    if(len<=0)
        return NULL;
    T=(tree)malloc(sizeof(tnode));
    char *p;
    T->data=*bef;
    for(p=mid;p!=NULL;p++)
        if(*p==*bef)
            break;
    int llen=p-mid;
    T->lc=creat(bef+1,mid,llen);
    T->rc=creat(bef+llen+1,p+1,len-llen-1);
    return T;
}
int countdepth(tree &T)
{
    int ldepth,rdepth;
    if(!T)
        return 0;
    else
    {
        ldepth=countdepth(T->lc);
        rdepth=countdepth(T->rc);
        return ldepth>rdepth?ldepth+1:rdepth+1;
    }
}
int main()
{
    tree T;
    char befs[60],mids[60];
    int len,depth;
    while(~scanf("%d",&len))
    {
        scanf("%s\n%s",befs,mids);
        T=creat(befs,mids,len);
        depth=countdepth(T);
        printf("%d\n",depth);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值