Catch That Cow

http://acm.sdut.edu.cn/sdutoj/showproblem.php?pid=1028&cid=1803

Catch That Cow

Time Limit: 2000MS Memory limit: 65536K

题目描述

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
农民约翰已经知道了一个逃亡的牛的位置,并想立即抓住它。他开始在一个点N(0≤N≤100000),牛是在点K(0≤K≤100000)。农夫约翰有两种行走方式:步行和传送。*行走:约翰可以从任何点x到点x-1或者x+1每分钟  *传送:约翰可以从任何点x到2*x每分钟。如果奶牛不动,农民约翰需要多长时间来抓住牛呢?

输入

Line 1: Two space-separated integers: N and K

输出

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

示例输入

5 17

示例输出

4

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
struct node
{
  int data;
  int step;
};
int vis[100010];
void bfs(int n,int k)
{
    int x;
    vis[n]=1;
    struct node v,s;
    queue<struct node>S;
    s.step=0;
    s.data=n;
    S.push(s);
    while(!S.empty())
    {
        v=S.front();
        S.pop();
        x=v.data;
        if(v.data==k)
        {
            printf("%d\n",v.step);
            return ;
        }
        if(v.data>=1&&!vis[v.data-1])
        {
            vis[v.data-1]=1;
            s.step=v.step+1;
            s.data=x-1;
            S.push(s);
        }
        if(v.data+1<=k&&!vis[v.data+1])
        {
            vis[v.data+1]=1;
            s.step=v.step+1;
            s.data=x+1;
            S.push(s);
        }
        if(2*v.data<=k&&!vis[2*v.data])
        {
            vis[2*v.data]=1;
            s.step=v.step+1;
            s.data=2*x;
            S.push(s);
        }
  }
}
int main()
{
    int n,k;
    scanf("%d%d",&n,&k);
    memset(vis,0,sizeof(vis));
    bfs(n,k);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值