1.3 SUM OF Consecutive Prime Numbers

离线计算 将连续素数存到数组中


POJ 2739

SUM OF Consecutive Prime Numbers

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20.
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2
package data20180220;

import java.util.ArrayList;
import java.util.List;
//POJ
import java.util.Scanner;

public class SumOfCPN {
    
    public static void main(String[] args) {
        
        List<Integer> list = new ArrayList<Integer>();
        for(int i=2;i<100001;i++){
            if(isPrime(i)==true){
                list.add(i);
            }
        }
        
        Scanner sc = new Scanner(System.in);
        int num = sc.nextInt();
        while(num!=0){
            int ans=0;
            for(int i=0;num>=list.get(i);i++){
                int sum=0;
                for(int j= i;sum<num&&j<=list.size();j++){
                    sum+=list.get(j);
                }
                if(sum==num){
                    ans++;
                }
            }
            System.out.println(ans);
            num = sc.nextInt();
        }    
    }
    
    public static Boolean isPrime(int k){
        
        for(int j=2;j<=Math.sqrt(k);j++){
            if(k%j==0){
                return false;
            }
        }
        return true;
    }
    
}

当日笔记:

数组 内存连续分配 索引速度快 利于赋值修改 不利于插入,移除。

指明长度 内存溢出或浪费。

ArrayList

动态扩充与收缩。

方便进行数据的添加、修改、插入与移除。

 可存多种类型的数据。装箱 拆箱操作 麻烦。

List:ArrayList类的泛型等效类。

       List不能被构造,但可以向上面那样为List创建一个引用,而ArrayList就可以被构造。

       Listlist = new List(); //错误。

List<int>list = new List<int>(); //正确。

List<int>list = new ArrayList<>();//正确。

 https://www.cnblogs.com/shouyeren/p/6201759.html

判断一个数是否为质数/素数:

 即n是否能被2-根号n的数整除如果能,则为素数 不能,则不是素数。

 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值