PTA第8章结构体与其他结构类型作业 6-5 删除链表中的指定结点 (10分)

本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中所有存储了某给定值的结点删除。链表结点定义如下:
struct ListNode {
int num;
char name[20];
int score;
struct ListNode *next;
};

函数接口定义:
struct ListNode *create();
struct ListNode *deleten( struct ListNode *head, int n );

函数readlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到0时表示输入结束,函数应返回指向单链表头结点的指针。
函数deletem将单链表中所有存储了n的结点删除。返回指向结果链表头结点的指针。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>

struct ListNode {
int num;
char name[20];
int score;
struct ListNode *next;
};

struct ListNode *create();
struct ListNode *deleten( struct ListNode *head, int n );
void print( struct ListNode *head )
{
struct ListNode *p =head;
while § {
printf("%d %s %d\n", p->num,p->name,p->score);
p = p->next;
}

}

int main()
{
int n;
struct ListNode *head = create();
scanf("%d", &n);
head = deleten(head,n);
print(head);
return 0;
}

/* 你的代码将被嵌在这里 */

输入样例1:
10001 wang 91
10002 zhang 92
10003 zhao 89
0
10002

输出样例1:
10001 wang 91
10003 zhao 89

输入样例2:
10001 wang 91
10002 zhang 92
10003 zhao 89
0
1002

输出样例2:
not find!
10001 wang 91
10002 zhang 92
10003 zhao 89

struct ListNode *create()
{
 int m=0;
 struct ListNode *head,*p1,*p2;
 p1=p2=(struct ListNode*)malloc(sizeof(struct ListNode));
 scanf("%d",&p1->num);
 head=NULL;
 while(p1->num!=0)
 {
  scanf("%s %d",p1->name,&p1->score);
  m=m+1;
  if(m==1)
  head=p1;
  else
  {
   p2->next=p1;
  }
  p2=p1;
  p1=(struct ListNode*)malloc(sizeof(struct ListNode));
  scanf("%d ",&p1->num);
 }
 p2->next=NULL;
 return(head);
}
struct ListNode *deleten( struct ListNode *head, int n )
{
 struct ListNode *p=head,*pr=head;
 if(head==NULL)
 {
  return(head);
 }
 while(n!=p->num&&p->next!=NULL)
 {
  pr=p;
  p=p->next;
 }
 if(n==p->num)
 {
  if(p==head)
  {
   head=p->next;
  }
  else
  {
   pr->next=p->next;
  }
  free(p);
 }
 else
 printf("not find!\n");
 return(head);
}

完整代码

#include <stdio.h>
#include <stdlib.h>
struct ListNode {
     int    num;
     char   name[20];
     int    score;
     struct ListNode *next;
};
struct ListNode *create()
{
 int m=0;
 struct ListNode *head,*p1,*p2;
 p1=p2=(struct ListNode*)malloc(sizeof(struct ListNode));
 scanf("%d",&p1->num);
 head=NULL;
 while(p1->num!=0)
 {
  scanf("%s %d",p1->name,&p1->score);
  m=m+1;
  if(m==1)
  head=p1;
  else
  {
   p2->next=p1;
  }
  p2=p1;
  p1=(struct ListNode*)malloc(sizeof(struct ListNode));
  scanf("%d ",&p1->num);
 }
 p2->next=NULL;
 return(head);
}
struct ListNode *deleten( struct ListNode *head, int n )
{
 struct ListNode *p=head,*pr=head;
 if(head==NULL)
 {
  return(head);
 }
 while(n!=p->num&&p->next!=NULL)
 {
  pr=p;
  p=p->next;
 }
 if(n==p->num)
 {
  if(p==head)
  {
   head=p->next;
  }
  else
  {
   pr->next=p->next;
  }
  free(p);
 }
 else
 printf("not find!\n");
 return(head);
}
void print( struct ListNode *head )
{
    struct ListNode *p =head;
    while (p)
 {
        printf("%d %s %d\n", p->num,p->name,p->score);
        p = p->next;
    }
} 
int main()
{
    int n;
    struct ListNode *head = create();
    scanf("%d", &n);
    head = deleten(head,n);
    print(head);
    return 0;
}
  • 2
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值