Vanya and Cards

 

Vanya and Cards

Description

The Little Elephant has an integer a, written in the binary notation. He wants to write this number on a piece of paper.

To make sure that the number a fits on the piece of paper, the Little Elephant ought to delete exactly one any digit from number a in the binary record. At that a new number appears. It consists of the remaining binary digits, written in the corresponding order (possible, with leading zeroes).

The Little Elephant wants the number he is going to write on the paper to be as large as possible. Help him find the maximum number that he can obtain after deleting exactly one binary digit and print it in the binary notation.

Input

The single line contains integer a, written in the binary notation without leading zeroes. This number contains more than 1 and at most 105 digits.

Output

In the single line print the number that is written without leading zeroes in the binary notation — the answer to the problem.

Sample Input

Input
101
Output
11
Input
110010
Output
11010

Sample Output

 

Hint

In the first sample the best strategy is to delete the second digit. That results in number 112 = 310.

In the second sample the best strategy is to delete the third or fourth digits — that results in number 110102 = 2610.

 

 

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
char a[100005];
int i,j,m,z;
int main()
{
   while(gets(a))
   {
       int count=0;
       int n=strlen(a);
       for(i=0;i<n;i++)
        if(a[i]=='0')
        count++;
         if(count<2)
        {
            for(i=0;i<n-1;i++)
                cout<<"1";
            cout<<endl;
        }
        else
        {
            if(a[n-1]=='0')
            {
                int count2=0;
                for(j=0;j<n-1;j++)
                {
                    if(a[j]=='0'&&count2==0)
                    {
                         m=j;
                         count2++;
                    }
                }
                for(i=0;i<n;i++)
                {
                    if(i!=m)
                        cout<<a[i];
                }
                cout<<endl;
            }
            else
            {
                int count1=0;
                for(i=0;i<n;i++)
                {
                    if(a[i]=='0'&&count1==0)
                    {
                        z=i;
                        count1++;
                    }

                }
                for(i=0;i<n;i++)
                {
                    if(i!=z)
                        cout<<a[i];
                }
                cout<<endl;

            }


        }

   }
   return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值