Pokemon Master

A - Pokemon Master
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Calem and Serena are pokemon masters. One day they decided to have a pokemon battle practice before Pokemon World Championships. Each of them has some pokemons in each's team. To make the battle more interesting, they decided to use a special rule to determine the winner: the team with heavier total weight will win the battle!

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N and M (1 <= NM <= 6), which describes that Calem has N pokemons and Serena has M pokemons.

The second line contains N integers indicating the weight of Calem's pokemons. The third line contains M integers indicating the weight of Serena's pokemons. All pokemons' weight are in the range of [1, 2094] pounds.

Output

For each test case, output "Calem" if Calem's team will win the battle, or "Serena" if Serena's team will win. If the two team have the same total weight, output "Draw" instead.

Sample Input

1
6 6
13 220 199 188 269 1014
101 176 130 220 881 396

Sample Output

Serena
#include<stdio.h>
#include<string.h>
int main()
{
  int a,b,i,n,aa,bb;
  scanf("%d",&n);
  while(n--)
  {
  	int s,s1;
  	s=s1=0;
  	scanf("%d%d",&a,&b);
  	for(i=0;i<a;i++)
  	{
	  	scanf("%d",&aa);
	  	s+=aa;
	  }
	  for(i=0;i<b;i++)
  	{
	  	scanf("%d",&bb);
	  	s1+=bb;
	  }
	  if(s>s1)puts("Calem");
	   else if(s<s1)puts("Serena");
	  else puts("Draw");
  }	
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值