1075 PAT Judge (25分)+测试点4修正

1075 PAT Judge (25分)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10
​4
​​ ), the total number of users, K (≤5), the total number of problems, and M (≤10
​5
​​ ), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained
where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:
For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] … s[K]
where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:
7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
Sample Output:
1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -


一开始提交的代码,测试点4未通过

#include<iostream>
#include<algorithm>
using namespace std;
const int MAXN=10010;
int full[6];//各题号的题目的满分分值
int N,K,M;
struct Student{
    int uid;//准考证号
    int score[6];//各题目获得的分数
    int total_score=0;//获得的总分
    int solve=0;//完美解题的题数
    bool submited=false;//标记该考试是否没提交没一道题目或者提交的题目都没有编译成功
}stu[MAXN];

bool cmp(Student s1,Student s2){
    if(s1.total_score!=s2.total_score){
        return s1.total_score>s2.total_score;
    }
    if(s1.solve!=s2.solve){
        return s1.solve>s2.solve;
    }
    return s1.uid<s2.uid;
}

int main(){  
    cin>>N>>K>>M;
    for(int i=1;i<=K;i++){
        scanf("%d",&full[i]);
    }
    for(int i=1;i<=N;i++){
        fill(stu[i].score,stu[i].score+6,-1);
    }
    int uid,pid,score;
    for(int i=0;i<M;i++){
        scanf("%d %d %d",&uid,&pid,&score);
        stu[uid].uid=uid;
        if(score!=-1){
            stu[uid].submited=true;
            if(score==full[pid]&&stu[uid].score[pid]<full[pid]){
                stu[uid].solve++;
            }
            if(score>stu[uid].score[pid]){
                stu[uid].score[pid]=score;
            }    
        }else if(score==-1){
            if(stu[uid].score[pid]==-1){
                stu[uid].score[pid]=0;
            }
        } 
    }
    //计算每位考生的总分
    for(int i=1;i<=N;i++){
        if(stu[i].submited==false) continue;
        for(int j=1;j<=K;j++){
            if(stu[i].score[j]==-1) continue;
            stu[i].total_score+=stu[i].score[j];
        }
    }
    //submited==true的考生一定会排在数组的最后面
    sort(stu+1,stu+N+1,cmp);
    //此处的rank可看作是前一位考生的排名
    int rank=1;
    for(int i=1;i<=N;i++){
        if(stu[i].submited==false) continue;
        if(i>1&&stu[i].total_score<stu[i-1].total_score){
            rank=i;
        }
        printf("%d %05d %d",rank,stu[i].uid,stu[i].total_score);
        for(int j=1;j<=K;j++){
            printf(" ");   
            if(stu[i].score[j]==-1){
                printf("-");
            }else{
                printf("%d",stu[i].score[j]);
            }
        }
        printf("\n");
    }
    return 0;
}

一开始是这么提交的,但是测试点4显示无法通过弄了半天终于找到原因!
因为submited==false的考生(也就是不参与排名,不会显示成绩的考生)的总分是0分,但是submited==true的考生的总分也有可能是0分,在用sort函数对其进行排序时,会将不参与排名的考生和参与排名的考生(submited==false和true)一起进行排序,这就导致数组中可能会出现submited==false的考生排在submited==true的考生前面,再来看下输出排名部分的代码。

if(stu[i].submited==false) continue;
        if(i>1&&stu[i].total_score<stu[i-1].total_score){
            rank=i;
        }
        printf("%d %05d %d",rank,stu[i].uid,stu[i].total_score);

当stu[i]的submited==true,但stu[i-1]的submited==false时,这种情况下两者的总分都为0分,这时会输出rank也就是上一个submited==true的考生的排名作为当前这个考生的排名,但是如果上一个submited==true的考生可能分数大于0,这就导致当前考生(总分0分)的排名和上一个总分大于0的考生排名相同。举个例子:

stu[5].total_score=10,stu[5].submited==true;//假如此时输出其排名为5,也就是rank=5。
stu[6].submited==false,stu[6].total_score=0;//这个会直接跳过,不进行输出
//此时就会将stu[7]和stu[6]总分进行比较,两者相同则直接输出rank,那就导致这里输出的排名和stu[5]相同,但是很明显这里输出的排名应该为6
stu[7].submited==false,stu[6].total_score=0;

改正后的代码

#include<iostream>
#include<algorithm>
using namespace std;
const int MAXN=10010;
int full[6];//各题号的题目的满分分值
int N,K,M;
struct Student{
    int uid;//准考证号
    int score[6];//各题目获得的分数
    int total_score=-1;//获得的总分
    int solve=0;//完美解题的题数
    bool submited=false;//标记该考试是否没提交没一道题目或者提交的题目都没有编译成功
}stu[MAXN];

bool cmp(Student s1,Student s2){
    if(s1.total_score!=s2.total_score){
        return s1.total_score>s2.total_score;
    }
    if(s1.solve!=s2.solve){
        return s1.solve>s2.solve;
    }
    return s1.uid<s2.uid;
}

int main(){  
    cin>>N>>K>>M;
    for(int i=1;i<=K;i++){
        scanf("%d",&full[i]);
    }
    for(int i=1;i<=N;i++){
        fill(stu[i].score,stu[i].score+6,-1);
    }
    int uid,pid,score;
    for(int i=0;i<M;i++){
        scanf("%d %d %d",&uid,&pid,&score);
        stu[uid].uid=uid;
        if(score!=-1){
            stu[uid].submited=true;
            stu[uid].total_score=0;
            if(score==full[pid]&&stu[uid].score[pid]<full[pid]){
                stu[uid].solve++;
            }
            if(score>stu[uid].score[pid]){
                stu[uid].score[pid]=score;
            }    
        }else if(score==-1){
            if(stu[uid].score[pid]==-1){
                stu[uid].score[pid]=0;
            }
        } 
    }
    //计算每位考生的总分
    for(int i=1;i<=N;i++){
        if(stu[i].submited==false) continue;
        for(int j=1;j<=K;j++){
            if(stu[i].score[j]==-1) continue;
            stu[i].total_score+=stu[i].score[j];
        }
    }
    //submited==true的考生一定会排在数组的最后面
    sort(stu+1,stu+N+1,cmp);
    //此处的rank可看作是前一位考生的排名
    int rank=1;
    for(int i=1;i<=N;i++){
        if(stu[i].submited==false) continue;
        if(i>1&&stu[i].total_score<stu[i-1].total_score){
            rank=i;
        }
        printf("%d %05d %d",rank,stu[i].uid,stu[i].total_score);
        for(int j=1;j<=K;j++){
            printf(" ");   
            if(stu[i].score[j]==-1){
                printf("-");
            }else{
                printf("%d",stu[i].score[j]);
            }
        }
        printf("\n");
    }
    return 0;
}

这里我将每位考生的总分设置默认为-1分,当在输入模块中确认该考试的submited==true时,将其总分设置为0分,这样就使得不参与排名的考生的总分一定为-1分,即不参与排名的开始的总分一定在参与排名的考生总分之后,这样也就不会影响后面输出排名的过程。

  • 5
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 4
    评论
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值