PAT甲级1075 PAT Judge (25 分)

1075 PAT Judge (25 )

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (104), the total number of users, K (5), the total number of problems, and M (105), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

      题目大意:

         一场PAT考试中有n个人,其中有k道题。给出m条记录,每个记录包含着用户id,题号及其得分。随后并给出每道题的总分。如果得分为-1则意味着未通过编译。要求按总分排名,如果总分相同者优先输出id小的。如果用户没有提交过某道题,某道题应当输出 “-”

 

思路:

         由于有控制输出,所有得分都初始化为-1。在打印时一旦遇到“-1”则可以输出“-”。要求每道题都选最高分的,这在录入分数的时候就可以解决。

         由于要知道哪些是否输出,所以要设立一个标志变量isshown用来判断是否输出。 每当得分不为-1的时候则确立为

参考代码:

 

#include<vector>
#include<cstdio>
#include<algorithm>
using namespace std;
struct node{
	int id, r, passnum, total;
	vector<int> score;
	bool isshown;
};
vector<node> list;
vector<int>full;
bool cmp(node a, node b){
	if(a.total != b.total) return a.total > b.total;
	else if(a.passnum != b.passnum)	return a.passnum > b.passnum;
	else return a.id < b.id;
}
int main(){
	int n, k, m;
	scanf("%d%d%d", &n, &k, &m);
	list.resize(n + 1), full.resize(k + 1);
	for(int i = 1; i <= n; ++i)	list[i].score.resize(k + 1, -1);
	for(int i = 1; i <= k; ++i)	scanf("%d", &full[i]);
	for(int i = 0; i < m; ++i){
		int id, num, score;
		scanf("%d%d%d", &id, &num, &score);
		list[id].id = id, list[id].score[num] = max(list[id].score[num], score);
		if(score != -1)	list[id].isshown = true;
		if(list[id].score[num] == -1)	list[id].score[num] = -2;
	}
	for(int i = 1; i <= n; ++i)
		for(int j = 1; j <= k; ++j){
			if(list[i].score[j] != -1 && list[i].score[j] != -2)	list[i].total += list[i].score[j];
			if(list[i].score[j] == full[j])	list[i].passnum++;	
		}
	sort(list.begin() + 1, list.end(), cmp);
	for(int i = 1; i <= n; ++i){
		list[i].r = i;
		if(i != 1 && list[i].total == list[i - 1].total)	list[i].r = list[i - 1].r;
	}
	for(int i = 1; i <= n; ++i)
		if(list[i].isshown){
		printf("%d %05d %d", list[i].r, list[i].id, list[i].total);
		for(int j = 1; j <= k; ++j)
			if(list[i].score[j] != -1 && list[i].score[j] != -2)	printf(" %d", list[i].score[j]);
			else if(list[i].score[j] == -1)	printf(" -");
			else 	printf(" 0"); 
		printf("\n");
		}
	return 0;
}

代码参考:https://blog.csdn.net/liuchuo/article/details/52226005

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值