Java高精度


Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201
解决方案:
Java中处理高精度问题用的是BigDecimal类
使用的BigDecimal类的时候需要注意的地方:
1. 在实例化BigDecimal 的时候用 new BigDecimal(String) 代替new BigDecimal(double) ,new BigDecimal(float)在《Effective Java》书中有提到 
2. 比较两个数的时候用compareTo小于返回-1,等于返回0 ,大于返回1
import java.io.*;
import java.util.*;
import java.lang.*;
import java.math.*;
class  GaoJingDu
{
public static void main(String[] args) throws Exception
{
Scanner cin=new Scanner(System.in);
Double r=cin.nextDouble();
int n=cin.nextInt();
BigDecimal bg=new BigDecimal(r.toString());
BigDecimal result=bg;
while((n--)>0)
{
result=result.multiply(bg,MathContext.UNLIMITED);


}
System.out.println(result.toString());
   

}
}

但是计算结果与测试结果不一致。分析可能是舍入以及精度控制的问题。进一步考虑后,发现自己所提供的算法是不精确的,BigDecimal类中已经提供了该方法,pow()方法,所以直接调用该方法就可以实现该功能了。代码如下:
import java.io.*;
import java.util.*;
import java.lang.*;
import java.math.*;
import java.io.IOException;  
class  GaoJingDu
{
public static void main(String[] args) throws Exception
{
Scanner cin=new Scanner(System.in);   //使用Scanner文本扫描器
try
{
 while(cin.hasNext())
 {
Double r=cin.nextDouble();
   int n=cin.nextInt();
   BigDecimal bg=new BigDecimal(r.toString());
   String result=null;

if(n==0)
result="1";
else if(n==1)
result=bg.toPlainString(); //toPlainString()方法,不使用科学计数法
else
result=bg.pow(n).toPlainString();
if(result.startsWith("0"))
{
result=result.substring(1);
}


            while ((result.endsWith("0") && result.contains("."))  //循环进行判断
                            || result.endsWith(".")) 
{  
                    //去尾数0或无意义的小数点  
                    result = result.substring(0, result.length() - 1);  
            }  
            if (result.length() == 0) 
{  
                    //所有操作后若字符串为空,则该数为0  
                    result= "0";  
            }  
            System.out.println(result);  


     }
   }
catch (Exception e)
{
e.printStackTrace();
        }
finally
{
cin.close();


}



}
}
输入方法可以用BufferedReader,代码如下:
BufferedReader bufr=new BufferedReader(new InputStreamReader(System.in));
String s=null;
while((s=bufr.readLine())!=null)
{
  .....
}
总结:
1.String类中的方法要掌握。
2.从键盘录入的流操作。Scanner,BufferedReader
3.高精度的计算,BigDecimal。










  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值