B - Sorting It All OutPOJ - 1094

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.
Input
Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character “<” and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
Output
For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy…y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy…y is the sorted, ascending sequence.
Sample Input
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0
Sample Output
Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

#include <iostream>

#include <vector>
#include <queue>
#include <cstring>
#include <cstdio>
using namespace std;
int m,n,sum,ff=0,zz=0;
vector<int> ve[30];
int s[30];
int co[30];
int sor[30];
int Find(int x,int y)
{
    for(int i=0;i<ve[x].size();i++)
    {
        if(ve[x][i]==y) return 1;
    }
    return 0;
}
int topsort()
{
    queue<int>qq;
    sum=0;
    for(int i=0;i<n;i++)
    {
        if(co[i]==0)
        {
            sor[sum++]=i;
            qq.push(i);
        }
    }
    int flag=0;
    while(!qq.empty())
    {
        if(qq.size()>1)
            flag=1;
        int p=qq.front();
        qq.pop();
        for(int i=0;i<ve[p].size();i++)
        {
            int t=ve[p][i];
            co[t]--;
            if(co[t]==0)
            {
                sor[sum++]=t;
                qq.push(t);
            }
        }
    }
    if(sum<n)return 1;
    else if(flag==1) return 2;
    else return 3;
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(m==0&&n==0) break;
        zz=0; ff=0;
        char q,w,e;
        if(m<n-1)
        {
            for(int i=0;i<m;i++)
                 cin>>q>>w>>e;
            printf("Sorted sequence cannot be determined.\n");
            continue;
        }
        memset(s,0,sizeof(s));
        for(int i=0;i<n;i++)
            ve[i].clear();
        for(int i=0;i<m;i++)
        {
            cin>>q>>w>>e;
            if(ff) continue;
            int a=q-'A';
            int b=e-'A';
            if(!Find(b,a))
            {
                s[a]++;
                ve[b].push_back(a);
            }
            for(int i=0;i<n;i++)
                co[i]=s[i];
            zz=topsort();
            if(zz!=2)
                ff=i+1;
        }
        if(zz==1)
            printf("Inconsistency found after %d relations.\n",ff);
        else if(zz==2)
             printf("Sorted sequence cannot be determined.\n");
        else
        {
            printf("Sorted sequence determined after %d relations: ",ff);
            for(int i=sum-1;i>=0;i--)
                printf("%c",sor[i]+'A');
            printf(".\n");
        }
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值