POJ-1094 Sorting It All Out 解题报告

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.


 
       题目链接:http://poj.org/problem?id=1094
       解法类型:拓扑排序
       解题思路:这几天看了下拓扑排序,于是就在POJ上找了一道题目练练手,一道很典型的拓扑排序题。建立一个邻接矩阵,然后深度搜索入度数为零的结点即可。但要做一些简单的剪枝,搜索到2个或者有回路就可以退出搜索了,这里一定要注意回溯!(我在这里被坑了= =!)。为了提高判断结点的入度数是否为零的效率,这里可以使用位运算,为了减小位运算的出错,最好写成宏定义。
       算法实现:
//STATUS:C++_AC_16MS_136K
#include<stdio.h>
#include<string.h>
#define get(u,v) (G[u]&(1<<v))     //位运算处理
#define put(u,v) (G[u]|=(1<<v))
const int MAXN=30;
char A[MAXN];
int topo_dfs(int cur);
int is_zero(int v);
int s,n,m,G[MAXN],map[MAXN],tot;
int main()
{
//	freopen("in.txt","r",stdin);
	int i,u,v,ok,result,w;
	char a,b,ch[5];
	while(~scanf("%d%d",&n,&m) && n)
	{
		tot=result=0;         //初始化
		memset(G,0,sizeof(G));
		memset(map,0,sizeof(map));
		getchar();

		for(i=0;i<m;i++){
			scanf("%c<%c\n",&a,&b);
			u=a-'A',v=b-'A';
			if(!get(u,v))put(u,v);       //位运算
			if(!map[u])map[u]=1,tot++;
			if(!map[v])map[v]=1,tot++;
			s=0;
			ok=topo_dfs(0);
			if(ok==-1){result=1;w=i+1;break;}
			else if(s==1){A[n]='\0';result=2;w=i+1;break;}
		}
		for(i++;i<m;i++)
			gets(ch);

		if(result==1)printf("Inconsistency found after %d relations.\n",w);    //按情况输出
		else if(result==2)printf("Sorted sequence determined after %d relations: %s.\n",w,A);
		else printf("Sorted sequence cannot be determined.\n");
	}
	return 0;
}

int topo_dfs(int cur)
{
	if(cur==n){s++;return 1;}
	if(s==2)return 2;    //有多个
	else if(cur==tot)return 3; //搜索完成
	int v,ok,t,ans;
	for(ok=0,v=0;v<n;v++){
		if( is_zero(v) && map[v] ){
			ok=1;
			t=G[v];      //位运算很方便的解决了赋值问题
			G[v]=0;
			map[v]=0;
			A[cur]=v+'A';
			ans=topo_dfs(cur+1);
			if(ans==-1)return -1;   //存在回路
			if(ans==2){G[v]=t;map[v]=1;return 2;}   //这里一定要注意剪枝和回溯
			if(ans==3){G[v]=t;map[v]=1;return 3;}   //这里一定要注意剪枝和回溯
			G[v]=t;
			map[v]=1;
		}
	}
	if(ok)return 0;
	else return -1;    //存在回路
}

int is_zero(int v)      //结点入度数是否为零
{
	for(int i=0;i<n;i++)
		if(get(i,v))return 0;
	return 1;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值