HDU1027——Ignatius and the Princess II(全排列)

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6991    Accepted Submission(s): 4140


Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?

 

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
 

Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
 

Sample Input
  
  
6 4 11 8
 

Sample Output
  
  
1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10
题意:
求N个数全排列,顺着数第M个(不知道能理解不);
解题思路:
先看m有大多,需要调整的数有几位,(比如m=4,那么就需要调整3位,因为2!<4<3!),咱们用t表示,再算出t-1位可以调整多少次(sum次),与m相比,若m能减去i个sum且m>0,说明下一位是后t位第i+1小的数,依次循环(这时需要调整的剩t-1位)。
代码实现(本人代码比较乱,建议看第二个,这个是给自己看的):
#include <iostream>
#include <cstdio>
#include <cmath>
#include <queue>
#include <cstring>
#include <algorithm>

using namespace std;
typedef long long LL;
const int maxn = 1000000+10;
int num[1000];
int n,m;

int main()
{
    while( ~scanf("%d%d",&n,&m) )
    {
        if( n==1 ){
            printf("1\n");
            continue;
        }
        memset(num,0,sizeof(num));
        for( int i=1; i<=n; i++ )
            num[i] = i;
        int yu,t=1;
        for( int i=2; i<=9; i++ )
        {
            yu = m - t;
            if( yu<=0 )
            {
                t = i-1;
                break;
            }
            t *= i;
        }
        for( int i=1; i<=n-t; i++ )
            printf("%d ",num[i]);
        vector<int>v;
        for( int i=n-t+1; i<=n; i++ )
            v.push_back(num[i]);
        int ans = n-t;
        while( m )
        {
            int lu,i,j;
            lu = n - ans - 1;
            int sum=1;
            for( i=1; i<=lu; i++ )
                sum *= i;
            if( lu == 0 )
                sum = 0;
            for( i=1; i<=lu; i++ )
            {
                if( m-sum <=0 )
                    break;
                m = m - sum;
            }
            if( lu==0 && m==1 )
                printf("%d\n",v[i-1]);
            else
                printf("%d ", v[i-1]);
            v.erase(v.begin()+i-1);
            ans++;
            if( ans == n )
                break;
        }
    }
    return 0;
}




咱们看神奇的第二种方法:
直接调用函数:STL库函数next_permutation(startAddress,endAddress)
#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
int N,M;
int sequence[1010];
int main()
{
 setbuf(stdout,NULL);
 while(scanf("%d %d",&N,&M)!=EOF)
 {
  int i;
  for(i=0;i<N;i++)
  {
   sequence[i]=i+1;
  }
  for(i=2;i<=M;i++)
  {
   next_permutation(sequence,sequence+N);
  }
  for(i=0;i<N-1;i++)
  {
   printf("%d ",sequence[i]);
  }
  printf("%d\n",sequence[N-1]);
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值