D - Ignatius and the Princess II (排列STL用法)

D - Ignatius and the Princess II

 
给你N个整数,分别是1,2,3,。。。N。问你全排列的第M个排列为多少?
Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file. 
Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number. 
Sample Input
6 4
11 8
Sample Output
1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
using namespace std;
int s[10000000];
int main(){
	int n,m;
	while(cin>>n>>m){
		int flag=1;
		int num=1;
		for(int i=0;i<n;i++){
			s[i]=num;
			num++;
		}
		/*for(int i=0;i<n;i++){
			cout<<s[i]<<endl;
		}*/
		int t=2;
		while(next_permutation(s,s+n)){
			
			if(t==m){
				for(int i=0;i<n;i++){
					if(flag==1){
						cout<<s[i];
						flag=0;
					}
					else{
						cout<<' '<<s[i];
					}
				}
				break;
			}
			t++;
		}
		cout<<endl;
	}
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值