hdu 1051 wooden sticks

Wooden Sticks




Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 
Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output




没什么特别想法
主要是先排序,按长度来排序。然后重量跟着长度变换就好,其实长度相等的时候重量怎么排序问题都不大,因为是根据这个数据是否处理过来进行处理数据的,用flag[]=1来标记这个数据未被处理,=0的时候就是处理过了,下次进行的时候就不对这个数据进行考虑。
长度排完序后,看看有多少组重量排序就有多少分钟。从最高位开始找起,因为排序是升序排序。
还要考虑当最后一个是独立一组的时候,分钟数直接加一就行,因为进入循环的话就是变成[0]与[-1]的比较,而[-1]并没有定义。
看了其他人的代码才有的想法,运用到贪心算法,虽然我还是不怎么理解这个算法,代码也比较繁杂,但是最近做了一点这类题还是有点收获的。

代码如下


#include <iostream>
using namespace std;

void bsort (int a[], int n, int b[]);

int main()
{
	int n;
	cin >> n;
	while(n--) {
		int n1;
		cin >> n1;
		int count = 0;
		int a[5001] = {0}, b[5001] = {0};
		int i = 0;
		int flag[5001]; 
		while(n1--) {
			cin >> a[i] >> b[i];
			flag[i] = 1;
			i++;
		}
		bsort(a, i, b);
		for(int k = i - 1; k >= 0; k--) {
			int w = k;
			if(flag[w]){
				if(w == 0) count++;
				else
					for(int q = w - 1; q >= 0; q--) {
						if(b[w] >= b[q] && flag[q] == 1) {
							flag[w] = 0;
							flag[q] = 0;
							w = q;
						}
						if(q == 0) count++;
					}
			}
		}
		cout << count << endl;
	}
}

void bsort (int a[], int n, int b[])
{
	int i, k;
	for(i = 0; i < n - 1; i++)
		for(k = 0; k < n - 1 - i; k++) {
			if(a[k] > a[k+1]) {
				int t = a[k];
				a[k] = a[k+1];
				a[k+1] = t;
				int q = b[k];
				b[k] = b[k+1];
				b[k+1] = q;
			}
		}
}


  
  
2 1 3
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值