/*你的弟弟刚做完了“100以内数的加减法”这部分的作业,请你帮他检查一下。
每道题目(包括弟弟的答案)的格式为a+b=c或者a-b=c,
其中a和b是作业中给出的,均为不超过100的非负整数;
c是弟弟算出的答案,可能是不超过200的非负整数,
也可能是单个字符"?",表示他不会算。
输入
输入文件包含不超过100行,以文件结束符结尾。每行包含一道题目,格式保证符合上述规定,且不包含任何空白字符。输入的所有整数均不含前导0。
输出
输出仅一行,包含一个非负整数,即弟弟答对的题目数量。
样例输入
1+2=3
3-1=5
6+7=?
99-0=99
样例输出
2*/
import java.util.*;
public class Main{
public static void main (String [] args){
Scanner sc = new Scanner(System.in);
int n = 0;
while (sc.hasNext()) {
String s = sc.nextLine();
int m = s.indexOf("+");
int q = s.indexOf("=");
int x = s.indexOf("-");
int y = s.indexOf("?");
if (y == -1) {
if (m == -1) {
int a = Integer.parseInt(s.substring(0, x));
int b = Integer.parseInt(s.substring(x + 1, q));
int c = Integer.parseInt(s.substring(q + 1));
if (a - b == c) {
n++;
}
} else {
int a = Integer.parseInt(s.substring(0, m));
int b = Integer.parseInt(s.substring(m + 1, q));
int c = Integer.parseInt(s.substring(q + 1));
if (a + b == c) {
n++;
}
}
}
}
System.out.println(n);
}
}