PAT 1143 Lowest Common Ancestor

原题链接:1143 Lowest Common Ancestor (30分)
关键词:树、LCA
The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found…
Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

分析:将前序遍历存储到数组中,用一个map来记录点是否在在树中。题目给的是BST,因此当u、v都在树中时,从前序遍历中第一个满足大小在u、v之间的数就是u、v的lca。
代码:

#include <iostream>
#include <vector>
#include <map>
using namespace std;

const int N = 10000 + 10;
int m, n;   //m询问结点对数 n二叉搜索树中的结点数量
int pre[N];    //前序遍历
map<int, int>pos;   //结点值 <-> 结点在前序遍历中的位置

int main(){
    scanf("%d%d", &m, &n);
    for(int i = 1; i <= n; i ++ ){
        cin >> pre[i];
        pos[pre[i]] = i;
    }
    
    for(int i = 0; i < m; i ++ ){
        int u, v;
        scanf("%d%d", &u, &v);
        if(pos[u] == 0 && pos[v] == 0) printf("ERROR: %d and %d are not found.\n", u, v);
        else if(pos[u] == 0 || pos[v] == 0) printf("ERROR: %d is not found.\n", pos[u] == 0 ? u : v);
        else{
            int father;
            for(int j = 1; j <= n; j ++ ){
                if(u <= pre[j] && pre[j] <= v || v <= pre[j] && pre[j] <= u){
                father =  pre[j];
                break;
                }
            }
            
            if(u == father || v == father){
                printf("%d is an ancestor of %d.\n", father, father != u ? u : v);
            }
            else {
                printf("LCA of %d and %d is %d.\n", u, v, father);
            }
        }
            
    }
    return 0;
}

遇到的问题:使用vector进行存储时(注意vector不能使用cin读入)会报Segmentation Fault
这是由于vector定义完后不能直接对pre[i]这样进行操作,需要先用pre.resize(10010); 之类的让它有东西。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值