PAT 1108 Finding Average

原题链接:PAT 1108 Finding Average

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:
For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

题目大意:

给出一组数,这组数里面存在不合法的值
判断每个数是否合法,以及输出合法数的平均值
合法输入数字指 [−1000,1000] 范围内的精确到不超过 2 个小数位的实数

方法一:字符串模拟

C++ 代码:

参考自:魔法学徒的代码

#include <iostream>
using namespace std;

int n, cnt = 0;	// cnt为合法的数的个数
double sum = 0; // sum为合法数的总和 

bool judge(string str){
	double x;
	try{
		size_t idx = sizeof(str); // size_t 记录大小 为sizeof的返回值类型 
    	x = stof(str, &idx); 
    	if (idx < str.size()) 
			return false;
	}
	// 如果有任何异常 说明不合法 
	catch(...){
		return false;
	}
    
    // 若范围不在[-1000, 1000]之间 
    if(x < -1000 || x > 1000)
    	return false;
    	
    // 若小数点后超过2位 
    int k = str.find('.');
    if(k != -1 && str.size() - 1 - k > 2)
    	return false;
	
	return true; 
}

int main(){
	cin >> n;
	while(n--){
		string num;
		cin >> num;
		
		if(judge(num)){
			cnt++;
			sum += stof(num);
		}
		else{
			cout << "ERROR: " << num <<  " is not a legal number" << endl;
		}
	} 
	
	if(cnt == 1)
		printf("The average of 1 number is %.2lf", sum / cnt);
	else if(cnt > 1)
		printf("The average of %d numbers is %.2lf", cnt, sum / cnt);
	else
		printf("The average of 0 numbers is Undefined");

	return 0;
} 

注:

  • 如果不适用try catch,会报terminate called after throwing an instance of 'std::invalid_argument' what(): stof 的错误
  • 3
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值