PAT 1154 Vertex Coloring

原题链接:1154 Vertex Coloring (25分)
关键词:图论、模拟

A proper vertex(顶点) coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.
Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

题目大意: 给定图的边和顶点的颜色,判断是否满足相邻顶点的颜色都不相同。
算法思路: 问题首先在于如何存储无向图的边:设置边的结构体,包含两个顶点,再定义该结构体的vector。读入每个点的颜色到数组中,同时存入set自动去重并统计颜色数目,遍历所有边,如果该边的两个顶点颜色相同就不满足 k-coloring
代码:

#include <iostream>
#include <vector>
#include <set>
using namespace std;

const int maxn = 10000 + 10;
int n, m, k;   //点和边的数量  方案数
struct edge{
    int n1, n2;
};  //边的结构体

int main(){
    scanf("%d%d", &n, &m);
    vector<edge> v(m);  //边
    //v.resize(m);
    for(int i = 0; i < m; i ++ ){
        scanf("%d%d", &v[i].n1, &v[i].n2);
    }
    
    scanf("%d", &k);
    
    for(int i = 0; i < k; i ++ ){   //k组测试用例
        bool flag = true;
        set<int> color; //颜色集
        int a[maxn] = {0}; //顶点的颜色
        for (int i = 0; i < n; i++) {
            scanf("%d", &a[i]);
            color.insert(a[i]);
        }
        
        for(int i = 0; i < m; i ++ ){
            if(a[v[i].n1] == a[v[i].n2]){
                flag = false;
                break;
            }
        }
        if(flag) printf("%d-coloring\n", color.size());
        else puts("No");
        
    }

    return 0;
}

注意的点:要考虑到作用域问题,数组和集合定义在循环内可以保证每次循环都使用新的;如果要定义在循环外,需要每趟循环结束clear一下。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值